Bug 193500 - [patch] Get beyond stage2 on Intel Mac's
[patch] Get beyond stage2 on Intel Mac's
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
https://www.opensolaris.org/jive/thre...
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 18:35 EDT by David Zeuthen
Modified: 2013-03-05 22:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 15:37:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (1.06 KB, patch)
2006-05-29 18:35 EDT, David Zeuthen
no flags Details | Diff

  None (edit)
Description David Zeuthen 2006-05-29 18:35:38 EDT
Description of problem:

When chainloading grub via NTLDR (the bootloader in Windows XP) using Bootcamp
on an Intel Mac grub can't go past stage 2. I've forward ported a patch from
grub 0.95 here

 https://www.opensolaris.org/jive/thread.jspa?threadID=7554&tstart=0

to 0.97 and now I can get past stage 2 and actually boot FC5 on my Macbook Pro.
As mentioned in the thread using the keyboard still freezes grub. Will file a
new bug once I have a patch for that.

Please consider applying this patch. Thanks.
Comment 1 David Zeuthen 2006-05-29 18:35:38 EDT
Created attachment 130196 [details]
Patch
Comment 2 Peter Jones 2006-05-30 15:37:14 EDT
Not a bug -- this patch is already in grub-0.97-5.1 and grub-0.97-6 .

Note You need to log in before you can comment on or make changes to this bug.