Bug 193574 - CVS loses track of conflicts
Summary: CVS loses track of conflicts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cvs   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-30 18:05 UTC by Jeff Gold
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: cvs-1.11.22-2.FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 06:02:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Gold 2006-05-30 18:05:11 UTC
Description of problem:

CVS in previous Fedora Core releases persistently reported conflicts until they
were resolved by the user.  Fedora Core 5 seems to do the same thing for local
repositories but at least in some cases it loses track of this for remote
repositories.

Version-Release: 1.11.21-3.2 (client) 1.11.2-13 (server)

Always reproducible:
1. Create a CVS repository with at least one file.
2. Check out the repository in two working trees.
3. Change a file in one tree and check it in.
4. Change the same file on the same line but in a different
   way in the other working tree.
5. Do a cvs update in the second tree and confirm that a conflict is reported.
6. Do another cvs update in the same place.
  
Actual results: No indication of a conflict.

  $ cvs -q up -dP
  RCS file: /home/user/cvsroot/test/README,v
  retrieving revision 1.1.1.1
  retrieving revision 1.2
  Merging differences between 1.1.1.1 and 1.2 into README
  rcsmerge: warning: conflicts during merge
  cvs update: conflicts found in README
  C README
  $ cvs -q up -dP
  $

Expected results: 

  $ cvs -q up -dP
  RCS file: /home/user/cvsroot/test/README,v
  retrieving revision 1.1.1.1
  retrieving revision 1.2
  Merging differences between 1.1.1.1 and 1.2 into README
  rcsmerge: warning: conflicts during merge
  cvs update: conflicts found in README
  C README
  $ cvs -q up -dP
  C README
  $

Comment 1 Martin Stransky 2006-08-11 13:20:41 UTC
You're right, the conflict isn't reported.

Comment 2 Martin Stransky 2006-08-11 13:51:38 UTC
Hmm, it works fine in cvs-1.11.22-4 (the latest rawhide), could you check it please?

Comment 3 Jeff Gold 2006-08-12 00:57:20 UTC
Will do.

Comment 4 Jeff Gold 2006-08-12 19:37:58 UTC
Unfortunately the 1.11.22-4 release doesn't install on FC5 because it needs
rtld(GNU_HASH).  I imagine that's related to some kind of linker improvement for
FC6?  Anyway, I'll have to setup a complete Rawhide development machine to test.
 That's doable, but I'll have to block out some time for that and I might not
get to it until later this week.

Comment 5 Martin Stransky 2006-08-12 22:03:33 UTC
I think 1.11.22-1.FC5 was released as a FC5 update, or am I wrong?

Comment 6 Jeff Gold 2006-08-13 20:45:01 UTC
At the moment a "yum update cvs" doesn't download or install anything and "rpm
-q cvs" reports cvs-1.11.21-3.2 for me.  Browsing the download server reachable
from http://fedora.redhat.com/ seems to show no entry for cvs in updates
directory.  I've tried again on a fully updated system to be sure and I am still
able to reproduce the problem with this version.

Comment 7 Martin Stransky 2006-08-14 08:16:54 UTC
Package cvs-1.11.22-2.FC5 should be available as a FC5 update today or tomorrow.

Comment 8 Martin Stransky 2006-08-14 21:31:30 UTC
The cvs-1.11.22-2.FC5 package is here:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/5/



Comment 9 Jeff Gold 2006-08-18 03:56:08 UTC
$ rpm -q cvs
cvs-1.11.22-2.FC5
$ cvs -q up -dP
RCS file: /cvs/project/README,v
retrieving revision 1.1.1.1
retrieving revision 1.2
Merging differences between 1.1.1.1 and 1.2 into README
rcsmerge: warning: conflicts during merge
cvs server: conflicts found in README
C README
$ cvs -q up -dP
C README

Yes, the problem seems to be fixed.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.