This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 193588 - yum-versionlock causes yum to fail w/o default config
yum-versionlock causes yum to fail w/o default config
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 193733 216966 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 16:00 EDT by Chris Weyl
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.0.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 06:54:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2006-05-30 16:00:51 EDT
Description of problem:
After installing yum-versionlock, yum fails with:

...snip....
extras                                                               [6/6]
extras                    100% |=========================| 1.1 kB    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.2 MB    00:01
extras    : ################################################## 3328/3328
Added 1465 new packages, deleted 300 old in 24.12 seconds
Excluding Packages from Dell Software
Finished
Reading version lock configuration


Unable to read version lock configuration: [Errno 5] OSError: [Errno 2] No such
file or directory: '/etc/yum/pluginconf.d/versionlock.list'

Version-Release number of selected component (if applicable):
0.6-2.fc5

How reproducible:
install yum-versionlock; try "yum update"

Actual results:
Fails on missing config file.

Expected results:
Succeeds with a default config file.

Additional info:
Probably as easy as throwing a default, do-nothing config file in the package.
Comment 1 Chris Weyl 2006-05-30 16:04:22 EDT
Sorry, substitute "lock list" everywhere I said "config" :)
Comment 2 Luke Macken 2006-06-01 19:52:31 EDT
*** Bug 193733 has been marked as a duplicate of this bug. ***
Comment 3 Seth Vidal 2006-11-28 01:09:08 EST
*** Bug 216966 has been marked as a duplicate of this bug. ***
Comment 4 Panu Matilainen 2007-01-11 13:01:42 EST
Failing in that situation is by design - if versionlock file can't be found (due
to for example temporary problem retrieving it over http) you don't want things
to proceed without locks at all.

Fixed in yum-utils 1.0.x in the sense that the plugin is disabled by default,
you need manual configuration for to use it anyway.
Comment 5 Tim Lauridsen 2007-02-14 06:54:19 EST
I have just added a blank versionlock.list to upstream CVS, because i was
working on some old bugzilla reports, i seams like it was not needed, because
versionlock is disabled by default now.
I will leave it in, because it don't hurt anything.

Note You need to log in before you can comment on or make changes to this bug.