Bug 19359 - assertion `image != NULL' failed.
assertion `image != NULL' failed.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-18 21:30 EDT by Michal Jaegermann
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 14:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2000-10-18 21:30:50 EDT
Every time gnome-terminal is opened (do that from another terminal to see
messages) the following shows up:

Gdk-CRITICAL **: file gdkimage.c: line 416 (gdk_image_destroy): assertion
`image != NULL' failed.

Gdk-CRITICAL **: file gdkimage.c: line 416 (gdk_image_destroy): assertion
`image != NULL' failed.

Gdk-CRITICAL **: file gdkimage.c: line 416 (gdk_image_destroy): assertion
`image != NULL' failed.

Gdk-CRITICAL **: file gdkimage.c: line 416 (gdk_image_destroy): assertion
`image != NULL' failed.


Should this Gdk-CRITICAL be not considered seriously?

  Michal
  michal@harddata.com
Comment 1 David Mason 2000-10-19 10:57:38 EDT
hp - I cannot reproduce, can you? --- michal
, prehaps try version on the released RH7 instead of the beta.
Comment 2 Havoc Pennington 2000-10-19 11:52:13 EDT
I can't reproduce it either; need more info on how to make it happen.
Comment 3 David Mason 2000-10-19 14:09:35 EDT
can reproduce on some alphas and not on others... reassigning to Sopwith... he
has an alpha :)
Comment 4 Michal Jaegermann 2000-10-19 14:43:40 EDT
Oh, in that case this is probably a type bug somewhere in a library. 
An intention is to check 'long', or a pointer, a value stuck there comes
as 'int' and the upper half of a value has in it a random garbage which
sometimes is zero and sometimes is not.  This is a _guess_!!

CRITICAL does not seem to be that critical as things appear to work just
fine after this initial noise.
Comment 5 Elliot Lee 2000-10-19 16:40:14 EDT
The warnings are generated because of incorrect error handling
in gtk+. I've fixed the error handling.

There is a separate issue with shared memory on the Alpha that makes these error
handlers even get hit, which is already being solved.

Note You need to log in before you can comment on or make changes to this bug.