Bug 193614 - typo in excludes in default mock config for x86_64
Summary: typo in excludes in default mock config for x86_64
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mock   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-31 06:31 UTC by Alexandre Oliva
Modified: 2013-01-10 01:25 UTC (History)
1 user (show)

Fixed In Version: 0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 04:41:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2006-05-31 06:31:56 UTC
Description of problem:
/etc/mock/default.cfg excludes *.486 and *.586, but that's missing an `i' after
the dot.  I'm not even sure why we should be excluding 32-bit packages on
x86_64, it looks like this probably breaks builds of say gcc, that require
32-bit glibc in order to build 32-bit sub-packages, which it needs to do even
when the target architecture is x86_64 only (the libraries are discarded, but
the GCC build machinery needs to build it to be happy)

The default [core] URL for development needs updating for the devel tree revamp
(/os is missing at the end of the URL), but you probably already know that, so
I'm not filing a separate bug report.

[local] simply doesn't work for me, should it perhaps be disabled by default, or
is it in flux too?

Version-Release number of selected component (if applicable):
mock-0.4-8.fc6

Comment 1 Seth Vidal 2006-06-01 17:34:27 UTC
some of the configs are wrong. We're planning a new release soon which should
fix both of those problems. We've recently been discussing the glibc* exception
on buildsys and fedora-devel.


Comment 2 Jesse Keating 2006-06-20 22:33:19 UTC
0.6 built, should fix this issue.


Note You need to log in before you can comment on or make changes to this bug.