This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 193626 - utrac: broken upgrade path
utrac: broken upgrade path
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: utrac (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alain Portal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-31 02:49 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 07:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-05-31 02:49:46 EDT
There are newer versions of utrac in older distro branches:

  3: 0:0.3.0-7.fc3
  4: 0:0.3.0-6.fc4
  5: 0:0.3.0-6.fc5
  6: 0:0.3.0-6.fc6

The FC-3 one is newer than the others.
https://www.redhat.com/archives/fedora-extras-list/2006-May/msg00083.html
Comment 1 Alain Portal 2006-05-31 03:46:55 EDT
This is not a newer version in FC3 branch.
0.3.0-7 is the same than 0.3.0-6.
I need to increase release tag because I made a mistake when I tagged the FC-3 
branch. I tagged the branch with wrong spec file and I didn't succeed to 
untag.

Do I have to increase release on all the others branchs?

%changelog
* Thu May 18 2006 Alain Portal <aportal[AT]univ-montp2[DOT]fr> 0.3.0-7
  - Increase release to fix a cvs error.

Comment 2 Ville Skyttä 2006-05-31 13:39:52 EDT
(In reply to comment #1)
> This is not a newer version in FC3 branch.

Yes it is, as far as rpm is concerned.

> I need to increase release tag because I made a mistake when I tagged the FC-3 
> branch.

Again, please look take a look at this post for instructions how to do that
without breaking the upgrade path:
https://www.redhat.com/archives/fedora-extras-list/2006-May/msg00083.html

> Do I have to increase release on all the others branchs?

If you think the current broken upgrade path should be fixed, then yes. 
Generally such things should be fixed (possibly different dependencies, compiler
security features etc).  I know nothing about utrac, so I can't tell what's the
case here, but again, see the above mailing list link how fixing old distro
versions can be done so that all newer ones do not require a rebuild.  (You
can't use that any more in this case, it has to be done beforehand, when making
the fix for the old branch.)
Comment 3 Alain Portal 2006-06-01 07:32:23 EDT
(In reply to comment #2)
> (In reply to comment #1)

> > Do I have to increase release on all the others branchs?
> 
> If you think the current broken upgrade path should be fixed, then yes. 

Done.

Note You need to log in before you can comment on or make changes to this bug.