Bug 193648 - device mapper multipath, missing devices
device mapper multipath, missing devices
Status: CLOSED DUPLICATE of bug 190357
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-05-31 08:14 EDT by Jose Plans
Modified: 2010-01-11 21:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-31 20:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
multipath.conf (2.23 KB, text/plain)
2006-05-31 08:14 EDT, Jose Plans
no flags Details
Using multipath -F: multipath -F; multipath; ls -al /dev/mpath (16.53 KB, text/plain)
2006-05-31 08:18 EDT, Jose Plans
no flags Details
This one is using dmsetup. (115.00 KB, text/plain)
2006-05-31 08:21 EDT, Jose Plans
no flags Details

  None (edit)
Description Jose Plans 2006-05-31 08:14:40 EDT
This is using RHEL4U3:
 Kernel 2.6.9-34.ELhugemem 
 device-mapper-1.02.02-3.0.RHEL4-i386
 device-mapper-multipath-0.4.5-12.0.RHEL4-i386

The problem:
  When flusing the multipath list, and generating a new one, sometimes the
number of devices listed in /dev/mpath is incorrect/different.

 For example:
   # dmsetup remove_all; multipath; ls /dev/mpath (output attached as koe.log)
   
   ls /dev/mpath:
   dm-0
   dm-1
   dm-2
   dm-3
   dm-4
   global_backup
   global_data
   global_log
   global_sw
   
   ls /dev/mpath: 
   backup
   dm-0
   dm-1
   dm-2
   dm-3
   dm-4
   dm-5
   global_backup
   global_data
   global_log
   global_sw

Or using multipath to flush the device list:

   # multipath -F; multipath; ls -al /dev/mpath (output attached in multipath_F.log)
   
   ls -al /dev/mpath:   
   total 0
   drwxr-xr-x  2 root root    160 May 22 11:53 .
   drwxr-xr-x  8 root root   4740 May 22 11:53 ..
   lrwxrwxrwx  1 root root     11 May 22 11:53 dm-0 -> global_data
   lrwxrwxrwx  1 root root     10 May 22 11:53 dm-2 -> global_log
   lrwxrwxrwx  1 root root     13 May 22 11:53 dm-3 -> global_backup
   brw-------  1 root root 253, 3 May 22 11:53 global_backup
   brw-------  1 root root 253, 0 May 22 11:53 global_data
   brw-------  1 root root 253, 2 May 22 11:53 global_log
   
   ls -al /dev/mpath:
   total 0
   drwxr-xr-x  2 root root    200 May 22 11:53 .
   drwxr-xr-x  8 root root   4720 May 22 11:53 ..
   lrwxrwxrwx  1 root root     11 May 22 11:53 dm-0 -> global_data
   lrwxrwxrwx  1 root root      9 May 22 11:53 dm-1 -> global_sw
   lrwxrwxrwx  1 root root     10 May 22 11:53 dm-2 -> global_log
   lrwxrwxrwx  1 root root     13 May 22 11:53 dm-3 -> global_backup
   brw-------  1 root root 253, 3 May 22 11:53 global_backup
   brw-------  1 root root 253, 0 May 22 11:53 global_data
   brw-------  1 root root 253, 2 May 22 11:53 global_log
   brw-------  1 root root 253, 1 May 22 11:53 global_sw
   
Both cases presents a difference in /dev/mpath after flusing or removing the
devices, this only happens from time to time so not always reproducible.
Let me know which actions I could take to assist this customer if I have missed
something in their configuration,
Comment 1 Jose Plans 2006-05-31 08:14:41 EDT
Created attachment 130266 [details]
multipath.conf
Comment 2 Jose Plans 2006-05-31 08:18:46 EDT
Created attachment 130267 [details]
Using multipath -F: multipath -F; multipath; ls -al /dev/mpath

The string XXX will show the wrong list of devices present in /dev/mpath
Comment 3 Jose Plans 2006-05-31 08:21:27 EDT
Created attachment 130269 [details]
This one is using dmsetup.
Comment 4 Ben Marzinski 2006-05-31 20:27:43 EDT

*** This bug has been marked as a duplicate of 190357 ***

Note You need to log in before you can comment on or make changes to this bug.