Bug 193677 - Upgrade fails on installation with lilo single-key
Upgrade fails on installation with lilo single-key
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-31 12:20 EDT by Chris Brand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 10:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Brand 2006-05-31 12:20:09 EDT
Description of problem:
I upgraded (from redhat 7.3, I believe) an installation that used the lilo
bootloader with the line "single-key" in lilo.conf.
When the installer modified lilo.conf, it added a new entry with a long label
(not a single character).
I presume that when it ran lilo, that failed (certainly, when I booted the
rescue toolkit and tried to run lilo, it failed).
The result was that after the upgrade, there was no sign of the new installation.

Version-Release number of selected component (if applicable):


How reproducible:
I don't want to try to reproduce it, but I would guess that it's easy to do so.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-06-04 14:19:57 EDT
Can you provide the complete traceback you received?
Comment 2 Chris Brand 2006-06-05 12:09:09 EDT
I don't believe I got a traceback. The installation appeared to complete
successfully, but when it booted aferwards, it booted the old (pre-upgrade) kernel.
Comment 3 Jeremy Katz 2006-06-19 17:51:24 EDT
Can you provide what your lilo.conf looked like?
Comment 4 Chris Brand 2006-06-19 18:00:46 EDT
I think that this is what I ended up with in lilo.conf after the installation
completed. I made it work by commenting-out the line "single-key" and re-running
lilo. I believe the installer added the block
"image=/boot/vmlinuz-2.6.16-1.2122_FC5" and changed the line "default=" and left
everything else the same.

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt          # display boot prompt
#vga=6           # vga 50 line mode
timeout=50      # 5 sec timeout
default=2.6.16-1.2122_F
single-key      # use single keypress, no return reqrd
lba32

image=/boot/vmlinuz-2.6.16-1.2122_FC5
        label=2.6.16-1.2122_F
        read-only
        append="idebus=66  pci=biosirq root=LABEL=/"
        initrd=/boot/initrd-2.6.16-1.2122_FC5.img

image=/boot/bzImage
        label=l
        root=/dev/hda3
        read-only
        append="idebus=66  pci=biosirq"

image=/boot/bzImage
        label=z
        root=/dev/hda3
        read-only
        append="idebus=66"
                                
image=/boot/bzImage.old.1
        label=m
        root=/dev/hda3
        read-only

#image=/boot/vmlinuz
        #label=f
        #root=/dev/hda3
        #read-only
Comment 5 Chris Lumens 2007-10-03 10:52:49 EDT
I am unable to reproduce this problem.  If you continue to experience it with
later releases of Fedora, please feel free to reopen this bug report.

Note You need to log in before you can comment on or make changes to this bug.