Bug 19369 - slapd doesn't call chdir after chroot
slapd doesn't call chdir after chroot
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openldap (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-19 04:35 EDT by Jarno Huuskonen
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-20 16:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarno Huuskonen 2000-10-19 04:35:49 EDT
Hi,

slapd doesn't call chdir after/before doing chroot -> leaves cwd outside of
chroot.
This bug is still in openldap-2.0.6 but should be fixed in future versions.

(The bug is in openldap-2.0.4/servers/slapd/main.c LINE 304)

-Jarno
Comment 1 Nalin Dahyabhai 2000-10-20 16:35:38 EDT
It appears that OpenLDAP 2.0.7 will be released within the next week or so.  If
it's not fixed then, I'll go ahead and patch the local copy.
Comment 2 Nalin Dahyabhai 2000-10-25 18:24:45 EDT
I've added a patch to openldap-2.0.6-4, though 2.0.7 will almost certainly make
it a duplication of effort.

Note You need to log in before you can comment on or make changes to this bug.