Bug 193700 - rsync errors when compression enabled
rsync errors when compression enabled
Status: CLOSED CURRENTRELEASE
Product: Fedora Legacy
Classification: Retired
Component: rsync (Show other bugs)
rhl7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-31 13:56 EDT by Systems Administrator
Modified: 2007-04-18 13:43 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.9-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 10:08:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Systems Administrator 2006-05-31 13:56:33 EDT
Description of problem:

getting errors between an rsync of two RHAT 7.3 boxes running the legacy package:

rsync -zar --force -e ssh --exclude='somedir/' --exclude'someotherdir/' /path/to/dir/* 
maustin@remotehost:~/somedir/

produces

deflate on token returned 0 (16384 bytes left)
rsync error: error in rsync protocol data stream (code 12) at token.c(288)

I found two threads with the errors mentioned
http://lists.samba.org/archive/rsync/2002-February/001391.html
http://lists.samba.org/archive/rsync/2003-April/005810.html


Version-Release number of selected component (if applicable):

rsync-2.5.7-2.legacy.7x

How reproducible:

always

Additional Info:

Removing the -z from the command line seems to be a work around for the legacy package.  That 
seems to isolate it down to an error with the compression library (as mentioned in the links)

Marc Deslauriers and I had a healthy exchange via email about this about a year ago . . . I never filed a 
bug but was cleaning out some old email and saw that I said I would ;)

Note You need to log in before you can comment on or make changes to this bug.