Bug 193722 - "xfs_db -c frag" segfaults
"xfs_db -c frag" segfaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Eric Sandeen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-31 16:31 EDT by Thomas Müller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: Fedora Core 6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 13:01:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for db/frag.c (610 bytes, patch)
2006-05-31 16:31 EDT, Thomas Müller
no flags Details | Diff

  None (edit)
Description Thomas Müller 2006-05-31 16:31:49 EDT
Description of problem:
When querying fragmentation information the xfs_db tool segfaults


Version-Release number of selected component (if applicable):
xfsprogs-2.7.3-1.2.1


How reproducible:
always


Steps to Reproduce:
1. create xfs filesystem
2. mount it
3. create a few random files
4. unmount it
5. run "xfs_db -c frag <device>"


Actual results:
Segmentation fault


Expected results:
Information about fragmentation


Additional info:
This looks like a known bug:
http://bugs.archlinux.org/task/3199
http://archives.free.net.ph/message/20051023.225451.f479ed5f.en.html
http://packages.debian.org/changelogs/pool/main/x/xfsprogs/xfsprogs_2.7.16-1/changelog
http://bugs.debian.org/338207

With attached patch applied, the tool runs without errors.

It looks like SGI already corrected this problem some time ago.
It's current version (2.7.11) corrensponds to the patch.

Easiest fix would be to bump xfsprogs to 2.7.11.
Comment 1 Thomas Müller 2006-05-31 16:31:49 EDT
Created attachment 130309 [details]
patch for db/frag.c
Comment 2 Eric Sandeen 2006-11-15 23:13:10 EST
newer xfsprogs (xfsprogs-2.8.11-3.fc6) is available now, so this should be fixed
in fc6.
Comment 3 Thomas Müller 2007-07-30 13:01:13 EDT
I think this can be closed now :)

Note You need to log in before you can comment on or make changes to this bug.