Bug 193746 - snd-usb-audio stopped working with ID 0d8c:000c C-Media Electronics, Inc.
snd-usb-audio stopped working with ID 0d8c:000c C-Media Electronics, Inc.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 03:29 EDT by Konstantin Antselovich
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-16 23:57:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Konstantin Antselovich 2006-06-01 03:29:00 EDT
Description of problem: snd-usb-audio stopped working in fedora kernels for USB
sound device based on C-Media Electr. chip. (see details below) The device is
Cyber Acoustics USB headset with a microphone
(http://geek.pricegrabber.com/search_getprod.php/masterid=7317423)

Does not work in 2.6.16-1.2108_FC4 and 2.6.16-1.2111_FC4 but it was working fine 
in 2.6.16-1.2096_FC4 


Version-Release number of selected component (if applicable): 2.6.16-1.2111_FC4


How reproducible: [always] plug the headset in to USB port -- no sound; check dmesg:
-----
cannot find the slot for index 1 (range 0-1)
cannot create card instance 0
snd-usb-audio: probe of 1-2:1.0 failed with error -5
-------


Steps to Reproduce:
1. plug the headset
2. enjoy the silence
3. check dmesg for errors
  
Actual results:
module snd-usb-audio fails to register with USB Audio Device


information:
 uname -a
Linux lifebook.myhome 2.6.16-1.2111_FC4 #1 Sat May 20 19:59:40 EDT 2006 i686
i686 i386 GNU/Linux

usb device:
Bus 001 Device 003: ID 0d8c:000c C-Media Electronics, Inc.

--- Let me know if any other info is needed.

Expected results:


Additional info:
Comment 1 Konstantin Antselovich 2006-06-01 05:21:38 EDT
===sorry, pls mark as solved or delete this bug===

I didn't RTFM.  

I apended 2 lines (below 2 modprobe.conf) and now it works.

alias snd-card-2 snd-usb-audio
options snd-usb-audio index=2

Rgds,
Konstantin
Comment 2 Dave Jones 2006-09-16 23:04:04 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 3 Konstantin Antselovich 2006-09-16 23:37:58 EDT
[code]
alias snd-card-2 snd-usb-audio
options snd-usb-audio index=2
[/code]

Confirm: works with FC5.

This bug can marked as resolved.

Rgds,
Konstantin
Comment 4 Dave Jones 2006-09-16 23:57:20 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.