Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 193750 - krb4 : Time is out of bounds when storing the time diff into unsigned int32
krb4 : Time is out of bounds when storing the time diff into unsigned int32
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: krb5 (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks: 190430 212183
  Show dependency treegraph
 
Reported: 2006-06-01 05:18 EDT by Jose Plans
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0435
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:38:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use signed integers for the local comparison between our (UNIX) walltime and the KDC's idea. Use abs() instead of "(if negative) then invert". Both required on 64bit (IA64, EM64T). (4.58 KB, patch)
2006-06-01 05:18 EDT, Jose Plans
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0435 normal SHIPPED_LIVE krb5 bug fix update 2007-06-07 18:34:43 EDT

  None (edit)
Description Jose Plans 2006-06-01 05:18:11 EDT
The krb4 libraries present a problem when trying to perform a difference of time
clockskew when being used in a 64bit environment.
Today the libraries stores the time difference within an unsigned 32bit integer,
and seems to be the cause of the problem when trying to perform the clockskew diff.
The customer has write a patch which consist of using long and abs() to solve
the problem for ia64 and x86_64 archs.

The affected package : krb5-libs-1.2.7-52.

To reproduce it:
   % /usr/kerberos/bin/kinit -4
   Logs generated:
   - kinit(v4): Time is out of bounds (krb_rd_req)

Attached is the patch they have provided to solve this problem,
jose
Comment 1 Jose Plans 2006-06-01 05:18:12 EDT
Created attachment 130326 [details]
Use signed integers for the local comparison between our (UNIX) walltime and the KDC's idea.
Use abs() instead of "(if negative) then invert".
Both required on 64bit (IA64, EM64T).
Comment 14 Red Hat Bugzilla 2007-06-11 14:38:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0435.html
Comment 15 Issue Tracker 2007-06-12 03:41:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0435.html

Internal Status set to 'Resolved'
Status set to: Closed by Tech
Resolution set to: 'RHEL 3.9'
Ticket type set to: 'Problem'

This event sent from IssueTracker by navid 
 issue 94413

Note You need to log in before you can comment on or make changes to this bug.