Bug 193798 - autofs has incorrect test for a config file in /etc/init.d/autofs
autofs has incorrect test for a config file in /etc/init.d/autofs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 14:08 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-15 20:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-06-01 14:08:38 EDT
Description of problem:

I was wondering why changes in /etc/sysconfig/autofs, and in particular
seting OPTIONS there, have no effect in a startup.  After looking closer
at /etc/init.d/autofs  I found that this does

if [ -x $confdir/autofs ]; then
        . $confdir/autofs
fi

while $confdir/autofs is NOT, and rightly so, executable.

After replacing '-x' with '-r' things started to work as expected.

Version-Release number of selected component (if applicable):
autofs-5.0.0_beta3-6
Comment 1 Ian Kent 2006-06-01 21:30:09 EDT
(In reply to comment #0)

Thanks again Michal.

> Description of problem:
> 
> I was wondering why changes in /etc/sysconfig/autofs, and in particular
> seting OPTIONS there, have no effect in a startup.  After looking closer
> at /etc/init.d/autofs  I found that this does

As it turns out this is the only option that is effected by this
as the config is read by the daemon itself at startup, except for
the OPTIONS variable which is meant for the init script only.

Oops.

I'll change the test in the init script straight away.

Ian
Comment 2 Ian Kent 2006-06-02 07:02:53 EDT
(In reply to comment #1)
> (In reply to comment #0)
> 
> Thanks again Michal.
> 
> > Description of problem:
> > 
> > I was wondering why changes in /etc/sysconfig/autofs, and in particular
> > seting OPTIONS there, have no effect in a startup.  After looking closer
> > at /etc/init.d/autofs  I found that this does
> 
> As it turns out this is the only option that is effected by this
> as the config is read by the daemon itself at startup, except for
> the OPTIONS variable which is meant for the init script only.
> 
> Oops.
> 
> I'll change the test in the init script straight away.
> 

Done.
Look for a new version of autofs autofs-5.0.0_beta4-1.

Ian

Comment 3 Ian Kent 2006-06-15 20:22:50 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > (In reply to comment #0)
> > 
> > Thanks again Michal.
> > 
> > > Description of problem:
> > > 
> > > I was wondering why changes in /etc/sysconfig/autofs, and in particular
> > > seting OPTIONS there, have no effect in a startup.  After looking closer
> > > at /etc/init.d/autofs  I found that this does
> > 
> > As it turns out this is the only option that is effected by this
> > as the config is read by the daemon itself at startup, except for
> > the OPTIONS variable which is meant for the init script only.
> > 
> > Oops.
> > 
> > I'll change the test in the init script straight away.
> > 
> 
> Done.
> Look for a new version of autofs autofs-5.0.0_beta4-1.

Fixed in autofs-5.0.0_beta4-1.

Note You need to log in before you can comment on or make changes to this bug.