Bug 193810 - Beagle fails to index powerpoint ppt files due to missing libgsf-1.so.1
Beagle fails to index powerpoint ppt files due to missing libgsf-1.so.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 15:03 EDT by Sean Carlos
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 10:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Carlos 2006-06-01 15:03:06 EDT
Description of problem:

Beagle fails to index powerpoint ppt files due to missing /usr/lib/libgsf-1.so.1
file.  This appears
to be a problem with the libgsf compliment to gsf-sharp?  libgsf-1.13.3-2.2.1
provides a libgsf-1.so link
to libgsf-1.so.113; Beagle looks for libgsf-1.so.1 , not provided.

See http://mail.gnome.org/archives/dashboard-hackers/2006-June/msg00008.html

Version-Release number of selected component (if applicable):

gsf-sharp-0.6-8
libgsf-1.13.3-2.2.1

beagle-0.2.6-1.fc5.1
libbeagle-0.2.6-1.fc5.1


How reproducible:

Try to manually parse a ppt file with beagle:

Steps to Reproduce:
1. $ beagle-extract-content /path to ppt file/ppt-file.ppt
  
Actual results:

Filename: file:///path to ppt file/ppt-file.ppt
Debug: Loaded 43 filters from /usr/lib/beagle/Filters/Filters.dll
Error: Unable to open /path to ppt file/ppt-file.ppt
libgsf-1.so.1
No filter for application/vnd.ms-powerpoint 

Expected results:

Text extracted from ppt file.

Additional info:

Creating link, 

ln -s libgsf-1.so.113 libgsf-1.so.1

seems to solve the problem - beagle-extract-content parses ppt files.  It is not
clear if these versions are the same....
Comment 1 Alexander Larsson 2006-06-21 10:46:28 EDT
Fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.