Bug 193829 - mirrors with greater than 1 addition leg do not work
mirrors with greater than 1 addition leg do not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cmirror (Show other bugs)
4
All Linux
high Severity high
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks: 180185
  Show dependency treegraph
 
Reported: 2006-06-01 17:49 EDT by Corey Marthaler
Modified: 2010-04-27 10:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 10:52:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2006-06-01 17:49:15 EDT
Description of problem:
I believe I was told that this may not work yet, but in case it is supposed to,
or incase a customer tries it, it doesn't work.

I tried to create a mirror with "-m 2" and it hung.

[...]
write(3, "2\0TE\0\0\0\0\0\0\0\0C\0\0\0\0\31\2040I9prx81Ohg7G"..., 85) = 85
read(3, "\1\0\0\0\0\0\0\0\0\0\0\0005\0\0\0\0t", 18) = 18
read(3, "aft-01\0\0\0\0\0\0taft-02\0\0\0\0\0\0taft-03"..., 53) = 53
stat("/dev/mirror_1/coreymirror2", {st_mode=S_IFBLK|0660, st_rdev=makedev(253,
10), ...}) = 0
stat("/dev/mirror_1/coreymirror2", {st_mode=S_IFBLK|0660, st_rdev=makedev(253,
10), ...}) = 0
stat("/dev/mirror_1/coreymirror2", {st_mode=S_IFBLK|0660, st_rdev=makedev(253,
10), ...}) = 0
open("/dev/mirror_1/coreymirror2", O_RDWR|O_DIRECT|O_NOATIME) = 5
fstat(5, {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 10), ...}) = 0
ioctl(5, BLKBSZGET, 0x68d928)           = 0
lseek(5, 0, SEEK_SET)                   = 0
read(5, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 4096
lseek(5, 0, SEEK_SET)                   = 0
write(5, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096       

Version-Release number of selected component (if applicable):
[root@taft-04 ~]# rpm -qa | grep lvm2
lvm2-cluster-2.02.06-1.0.RHEL4
lvm2-cluster-debuginfo-2.02.01-1.2.RHEL4
lvm2-2.02.06-3.0.RHEL4
[root@taft-04 ~]# rpm -qa | grep cmirror
cmirror-1.0.0-5
cmirror-kernel-smp-2.6.9-4.2

How reproducible:
everytime
Comment 1 Jonathan Earl Brassow 2006-06-02 18:02:18 EDT
Could you recheck this when the build with fixes for 193706 and 193596 comes
out?  (next build after cmirror-kernel*-2.6.9-4.2)
Comment 2 Jonathan Earl Brassow 2006-06-02 18:03:35 EDT
wrong bugzilla for that last comment...
Comment 3 Jonathan Earl Brassow 2006-06-02 18:52:51 EDT
Hmmm, just tried this and it seems to work for me (at least the creation).  Your
trace may be attempting to zero the log - not sure why that would fail.
Comment 5 Jonathan Earl Brassow 2006-07-06 00:29:46 EDT
I'm sorry, I haven't seen this.  However, I do have a script which produces a similar problem durring 
recovery.  It had to do with scanning devices while suspended...  That issue has been fixed and agk 
should be rebuilding packages now (available by 7/6/6 meeting?).

Could you please retest?
Comment 6 Corey Marthaler 2006-07-07 16:54:32 EDT
This does appear to work now, and when it doesn't I believe it's due to bz 195392. 
Comment 8 Alasdair Kergon 2010-04-27 10:52:53 EDT
Assuming this VERIFIED fix got released.  Closing.
Reopen if it's not yet resolved.

Note You need to log in before you can comment on or make changes to this bug.