Bug 193837 - paraview-demos, paraview-data subpackages are missing Requires:
paraview-demos, paraview-data subpackages are missing Requires:
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: paraview (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 20:26 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.3-7.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 12:22:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-06-01 20:26:40 EDT
Description of problem:
The subpackages paraview-demos and paraview-data are missing the appropriate:

Requires: paraview

Presumably both the -demos and the -data subpackages are fairly useless without
the main paraview package, each subpackage should require the main package.

Version-Release number of selected component (if applicable):
paraview-2.4.3-6.fc4

How reproducible:
Always

Steps to Reproduce:
1.  smart install paraview-data paraview-demos

  
Actual results:
Loading cache...
Updating cache...              ######################################## [100%]

Computing transaction...

Installed packages (2):
  paraview-data-2.4.3-6.fc4@i386        paraview-demos-2.4.3-6.fc4@i386

7.1MB of package files are needed. 27.4MB will be used.

Confirm changes? (Y/n): y

Fetching packages...
-> http://fedoraproject.org/extras/4/i386/paraview-demos-2.4.3-6.fc4.i386.rpm
-> http://fedoraproject.org/extras/4/i386/paraview-data-2.4.3-6.fc4.i386.rpm
paraview-demos-2.4.3-6.fc4.i.. ######################################## [ 50%]
paraview-data-2.4.3-6.fc4.i3.. ######################################## [100%]


Committing transaction...
Preparing...                   ######################################## [  0%]
   1:Installing paraview-data  ######################################## [ 50%]
   2:Installing paraview-demos ######################################## [100%]



Expected results:
paraview should also be installed

Additional info:

$ rpm -q paraview-demos --requires
paraview-data = 2.4.3-6.fc4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

and:

$ rpm -q paraview-data --requires
/bin/sh
/bin/sh
/usr/bin/update-mime-database
/usr/bin/update-mime-database
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

shows that paraview does not appear in the list of explicit (or implict) Requires.
Comment 1 Orion Poplawski 2006-06-05 12:22:54 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.