Bug 193885 - 'pam_opensc' not compatible with FC5
'pam_opensc' not compatible with FC5
Product: Fedora
Classification: Fedora
Component: pam_pkcs11 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bob Relyea
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-06-02 14:09 EDT by James Turansky
Modified: 2008-05-06 11:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 11:58:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
These are the files/patches needed & the instructions I wrote up, after I figured out how to setup the eToken under FC4. (2.77 MB, application/zip)
2006-06-02 14:09 EDT, James Turansky
no flags Details

  None (edit)
Description James Turansky 2006-06-02 14:09:25 EDT
Description of problem:

After upgrading my PC from FC4 to FC5. All went well, except when I tried to use
my PKCS#15 configured eToken. I found that there was no 'pam_opensc' RPM
available within any FC5 repositories. I tried to force the FC4 RPM, but FC5
would not use it. FC5 complained about missing various FC4 packages.  No SPRM
packages for the 'pam_opensc' package seam to exist & after extensively
searching the web, I could not find an replacement package or work around to get
my PKCS#15 eToken working with FC5.  This was never a problem with FC4.  Linux
newsgroups have been litte to no help on the issue.

Version-Release number of selected component (if applicable):

"pam_opensc-0.9.6-2.i386.rpm" is the most currect FC4 pam_opensc package that
appears to be available.

How reproducible:

Easily reproduced.

Steps to Reproduce:
1. Start with an Aladdin Pro32k eToken & use the attacted instructions under FC4
top setup.
2. Then upgrade Fedora from FC4 to FC5.
3. The eToken will no longer be authenticated, because the 'pam_opensc' package
is missing under FC5

Actual results:

Results are as follows from within FC5, when trying to authenticate the eToken
without the 'pam_opensc' package.

# /opt/openssh-4.3p2/bin/ssh -X -I 0 username@mydomain.com
card-cardos.c:225:cardos_check_sw: required access right not granted
card-cardos.c:746:do_compute_signature: returning with: Security status not
sec.c:53:sc_compute_signature: returning with: Security status not satisfied
pkcs15-sec.c:331:sc_pkcs15_compute_signature: sc_compute_signature() failed:
Security status not satisfied
sc_pkcs15_compute_signature() failed: Security status not satisfied
ssh_rsa_sign: RSA_sign failed: error:00000000:lib(0):func(0):reason(0)
Permission denied (publickey).

Expected results:

- prompted for the eToken password.
- once password is entered, will instantly gain access to SSH command line on
given server.

Additional info:

- Will provide additional information/files as needed.
Comment 1 James Turansky 2006-06-02 14:09:26 EDT
Created attachment 130416 [details]
These are the files/patches needed & the instructions I wrote up, after I figured out how to setup the eToken under FC4.
Comment 2 Tom "spot" Callaway 2006-09-11 10:59:03 EDT
Looks like this needs several different things:

- A patch to openssh to support prompting for pin (please open a bug against
openssh in rawhide)
- Testing with pam_pkcs11 in FC-6 when it releases.

This package never quite made it into Fedora Extras, because Fedora Core needed
it for FC-6. I'm reassigning it to the Fedora Core maintainer, and pushing this
to FC-6.
Comment 3 petrosyan 2008-02-16 18:27:24 EST
Fedora Core 5 is no longer maintained.

Can you reproduce this bug in Fedora 8?
Comment 4 Bug Zapper 2008-04-03 23:01:05 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2008-05-06 11:58:15 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.