Bug 193948 - autofs fails to use NIS auto.master map
autofs fails to use NIS auto.master map
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 00:17 EDT by Matt Domsch
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: autofs-5.0.1-0.rc2.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 11:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to include syntax "--timeout <secs>" as valid for backward compatibility with autofsv3 and v4 (625 bytes, patch)
2006-10-06 04:10 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description Matt Domsch 2006-06-03 00:17:08 EDT
Description of problem:
autofs-5.0.0_beta3-6 fails to obtain the auto.master map from NIS, thus fails to
get auto.home and to use it.  Versions as recently as 2 weeks ago in rawhide did
work in the same network configuration.  SELinux is not enabled on this system.

Version-Release number of selected component (if applicable):
autofs-5.0.0_beta3-6

How reproducible:
unknown

Steps to Reproduce:
1. upgrade to rawhide, a system using NIS to obtain auto.master
2.
3.
  
Actual results:
autofs fails to handle mountpoints specified in auto.master's child tables

Expected results:
autofs handles those mountpoints as expected

Additional info:
Comment 1 Ian Kent 2006-06-15 20:19:40 EDT
(In reply to comment #0)
> Description of problem:
> autofs-5.0.0_beta3-6 fails to obtain the auto.master map from NIS, thus fails to
> get auto.home and to use it.  Versions as recently as 2 weeks ago in rawhide did
> work in the same network configuration.  SELinux is not enabled on this system.

Hi Matt,

As you probably know we've lost a bit of history and I'm trying to
bring my bzs up to date.

Quite a bit of work has been done since this call was logged and I
can't find anything in my email from you about this.

Could you let me know if this is still a problem with the latest
Rawhide package please.

Ian
Comment 2 Ian Kent 2006-07-02 22:02:29 EDT
Heard nothing back on this.
Should be resolved in current revision.
Comment 3 Orion Poplawski 2006-09-20 11:41:20 EDT
I'm reopening because I appear to be having the same problem with
autofs-5.0.1-0.rc2.1.

/etc/auto.master:
#
# $Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
/misc   /etc/auto.misc
/net    /etc/auto.net
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master


# grep auto /etc/nsswitch.conf
automount:  nis files


# ypcat auto.master
auto.fs         intr
auto.opt        intr,rsize=8192,wsize=8192
auto.data       intr
auto.home       intr
auto.data4      fstype=nfs4,intr,rsize=32768,wsize=32768


# ypcat auto.opt
hawk:/export/web
earth:/export/local
earth:/export/local/intel


# ls /opt/local
ls: /opt/local: No such file or directory


Sep 20 09:40:12 sombrero automount[15292]: attempting to mount entry /opt/local
Sep 20 09:40:12 sombrero automount[15292]: mount(nfs): nfs: mount failure
earth:/export/local on /opt/local
Sep 20 09:40:12 sombrero automount[15292]: lookup_name_file_source_instance:
file map not found
Sep 20 09:40:12 sombrero automount[15292]: attempting to mount entry /opt/local
Sep 20 09:40:12 sombrero automount[15292]: lookup_name_file_source_instance:
file map not found
Sep 20 09:40:12 sombrero automount[15292]: failed to mount /opt/local


This all works out of the box on FC5.


Comment 4 Orion Poplawski 2006-09-22 16:07:47 EDT
Sorry, different issue.   Opening a new bug.
Comment 5 Matt Domsch 2006-10-05 12:13:25 EDT
autofs-5.0.1-0.rc2.4 stills fails for me.  It fails parsing the NIS-provided 
auto.master map.

lookup_nss_read_master: reading master files auto.master
lookup_nss_read_master: reading master nis auto.master
lookup_init: lookup(yp): ctxt->mapname-auto.master
master_echo: -
master_error: syntax error while parsing map.
master_notify: syntax error in map near [ bogus option ]

# ypcat -k auto.master
/home auto.home --timeout 60

# ypcat -k auto.home
* -udp,hard,intr  myserver:/home/&

Note, this exact same setup has worked fine up and until FC6 devel started.  
FC5 and earlier, RHEL4 and earlier, RHLx and earlier, since RHL6.0.


Comment 6 Ian Kent 2006-10-05 13:09:42 EDT
(In reply to comment #5)
> master_error: syntax error while parsing map.
> master_notify: syntax error in map near [ bogus option ]
> 
> # ypcat -k auto.master
> /home auto.home --timeout 60

Could you replace "--timeout 60" with "--timeout=60" and
see how that goes.

Ian


Comment 7 Matt Domsch 2006-10-05 14:45:12 EDT
success with --timeout=60

However, that isn't a backwards-compatible change.  A quick check of a SLES9 
system with autofs-3.1.7 notes that this change causes autofs to fail exactly 
because the equals sign *is* there.  The parsing needs to deal with it present 
or not (e.g. getopt style).
Comment 8 Ian Kent 2006-10-05 23:19:37 EDT
(In reply to comment #7)
> success with --timeout=60
> 
> However, that isn't a backwards-compatible change.  A quick check of a SLES9 
> system with autofs-3.1.7 notes that this change causes autofs to fail exactly 
> because the equals sign *is* there.  The parsing needs to deal with it present 
> or not (e.g. getopt style).

OK.

Sory for the misunderstanding but I didn't mean to imply that
I wouldn't change this by asking you to check it.

That question was the next step in the investigation and
you've answered it.

I'll amend the parser and post a patch for testing.

Ian
Comment 9 Ian Kent 2006-10-06 04:10:35 EDT
Created attachment 137904 [details]
Patch to include syntax "--timeout <secs>" as valid for backward compatibility with autofsv3 and v4

Can you give this patch a test please.
It works for me.
Comment 10 Matt Domsch 2006-10-12 11:15:11 EDT
This patch works for me too.  Thanks much!  Closing.

Note You need to log in before you can comment on or make changes to this bug.