Bug 193985 - perl-XML-Simple: must require perl-XML-Parser and/or perl-XML-SAX
perl-XML-Simple: must require perl-XML-Parser and/or perl-XML-SAX
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-XML-Simple (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 18:40 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-15 11:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2006-06-03 18:40:13 EDT
Description of problem:
The package perl-XML-Simple must require ate least one of the following packages:
 - perl-XML-SAX
 - perl-XML-Parser (fallback if perl-XML-SAX)

Affects both the rawhide and FC-5 versions and also the Fedora Extras versions
(<FC-5).
Comment 1 Jose Pedro Oliveira 2006-06-03 18:46:51 EDT
Mathias,

The missing requirement has been exposed by the recent massive rebuilds of FC-6
(rawhide) and Fedora Extras development in mock but using a reduced building root
(perl-XML-Parser is no longer installed in this build root).

For example, perl-Image-Info fails the at least on test due to this missing
requirement in perl-XML-Simple.  For the complete build log see 
 https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=193498.

Could you add the perl-XML-Parser requirement to the rawhide version so that we
could make a couple of more tests?

Thanks in advance,
jpo
(the FE maintainer of perl-XML-Simple)
Comment 2 Jose Pedro Oliveira 2006-06-03 18:50:29 EDT
For more details about the missing requirement see the code of the build_tree
function in the Simple.pm file.  Rpmbuild never adds the perl modules in
requirement statments to the requirments list.

jpo
Comment 3 Jason Vas Dias 2006-06-07 17:00:22 EDT
Now fixed with perl-XML-Simple-2.14-4.fc5, being released to FC-5/Updates/Testing
- perl-XML-Simple now
'BuildRequires: perl(XML::Parser) perl(XML::SAX) perl(XML::LibXML)
perl(XML::LibXML::Common)'
(see bug 191911).


Comment 4 Fedora Update System 2006-06-07 19:39:42 EDT
perl-XML-Simple-2.14-4.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Jose Pedro Oliveira 2006-06-15 11:13:38 EDT
Re-closing (with some comments lost due to hardware failure).

Note You need to log in before you can comment on or make changes to this bug.