Bug 194041 - Weird problem with nfs-utils-1.0.5-3
Weird problem with nfs-utils-1.0.5-3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-05 07:01 EDT by Rajdeep Sengupta
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajdeep Sengupta 2006-06-05 07:01:17 EDT
Description of problem:
On eof our NFS server is having nfs version 1.0.5-3, though this is a stable 
version, but I am expereincing failure of rpc.mountd deamon when the below 
mention scenario is met.
Say there is a client machine with IP 192.168.1.10, its name in NIS is apple, 
now the machine is accessing the NFS server properly. 

Let say you have changed the IP address of this apple machine from 
192.168.3.10 to say 192.168.1.11 and updated the NIS database, so that 
whenever the any machine on the domain contacts apple machine it will resolve 
to 192.168.3.11.
But the NFS server rpc.mountd will fail and to rectify it, you have restart 
the nfs server.
while restating you will find that mountd had already failed.

I have looked into the issue and found that some file in /var/lib/nfs/rmtab 
which keeps the info of client mounted on the nfs server, so as far as I have 
understood, the nfs server while running is somehow unable to recognize this 
change and whole rpc.mountd fails.
But I am not cofirmed about this.


Version-Release number of selected component (if applicable):
1.0.5-3

How reproducible:
ALready mentioned

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve Dickson 2006-07-18 14:49:40 EDT
Try updating your nfs-utils to the latest version since there was a bug fix
for something simlar to what your seeing... 
Comment 2 Rajdeep Sengupta 2006-07-19 04:11:24 EDT
to which version I should upgrade.
My server OS version is RHEL3. So if I update the nfs-utils to latest version, 
would it create any other problem?
Comment 3 Steve Dickson 2006-07-20 08:44:02 EDT
nfs-utils-1.0.6-44EL is the lasted RHEL3 version
Comment 4 Rajdeep Sengupta 2006-07-20 09:07:51 EDT
Can you confirm, whether we can directly load this version on my nfs server.
My NFS server version is

Red Hat Enterprise Linux WS release 3 (Taroon)
Linux whale 2.4.21-4.ELsmp #1 SMP
Comment 5 Steve Dickson 2006-07-20 09:45:38 EDT
Yes, nfs-utils-1.0.6-44EL will work with 2.4.21-4.ELsmp
Comment 6 RHEL Product and Program Management 2007-10-19 14:43:26 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.