This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 194077 - upstream perl bugs fixed since 5.8.8 was released
upstream perl bugs fixed since 5.8.8 was released
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
David Lawrence
:
Depends On:
Blocks: 199149
  Show dependency treegraph
 
Reported: 2006-06-05 13:34 EDT by Jason Vas Dias
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 12:19:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2006-06-05 13:34:54 EDT
Description of problem:

These upstream perl bugs / issue  have beed fixed in the upstream 
5.8.x maintenance release of perl since perl-5.8.8 was released:

o 38454 - 'rindex corrects for $[ on bytes rather than UTF-8'
  http://rt.perl.org/rt3/index.html?q=38454
  apply upstream patch #27116

o 24816 - 'Magic vars seem unsure if they are purely numeric' 
  http://rt.perl.org/rt3/index.html?q=24816
  ( perl -wle 'print $? = $? ^ "3"' -> 'Argument "^C" isn't numeric' )
  apply upstream patch #27391

o Avoid writing over the input string in the case 'F' in moreswitches.
  apply upstream patch #27426

o 34925 - 'overload and rebless' 
  http://rt.perl.org/rt3/index.html?q=34925
  apply upstream patches #27509, #27512

o 3038 - '$qr = qr/^a$/m; $x =~ $qr; fails'
  http://rt.perl.org/rt3/index.html?q=3038
  apply upstream patch #27604

o apply upstream patch #27605 - 'Fix off-by-one in $0 set magic.'

o 23141 - '($_) = () fails to set $_ to undef'
  http://rt.perl.org/rt3/index.html?q=23141
  apply upstream patch #27914

o 38619 - 'Bug in lc and uc (interaction between UTF-8, substr, and lc/uc)'
  http://rt.perl.org/rt3/index.html?q=38619
  apply upstream patch #27329

Version-Release number of selected component (if applicable):
perl-5.8.8-4

How reproducible:
100%

Steps to Reproduce:
See upstream bug reports and the new RHTS test cases in CVS perl/perl-tests/FC6 .
Comment 1 Jason Vas Dias 2006-06-05 13:36:03 EDT
Fixed in perl-5.8.8-6 (FC-6) and perl-5.8.8-5 (FC5).
 
Comment 2 Fedora Update System 2006-06-05 17:01:24 EDT
perl-5.8.8-5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Robin Norwood 2006-10-01 19:26:27 EDT
assigning to rnorwood@redhat.com

Note You need to log in before you can comment on or make changes to this bug.