Bug 194085 - New appointments are classified as "Private" even when "Public" was selected
New appointments are classified as "Private" even when "Public" was selected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-05 13:46 EDT by Per Nystrom
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-2.8.2.1-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 12:37:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Nystrom 2006-06-05 13:46:41 EDT
Description of problem:  New appointments made in Exchange calendars get set to
"Private" Classification, even if "Public" was selected.


Version-Release number of selected component (if applicable): 2.6.1-1.fc5.1


How reproducible: Random?


Steps to Reproduce:
1. Start creating a new appointment in an Exchange calendar.
2. Set the Classification Option to "Public".
3. Save the appointment.
  
Actual results:

Appointment appears on the calendar as "Private".

Expected results:

Appointment should appear as "Public".

Additional info:

As a separate RFE, can the appointment classification be displayed in the
dialog, instead of buried in the Options menu?  This is how it used to be...
Comment 1 Per Nystrom 2006-06-05 13:51:39 EDT
This also happens in local Evolution calendars, though that's not as much of a
concern to me since local calendars are not shared to others.
Comment 2 Per Nystrom 2006-06-08 13:33:12 EDT
Changed component from evolution-connector to evolution.  This appears to affect
local calendars as well as Exchange calendars.

This bug is still present after updating to evolution-2.6.2-1.fc5.5.
Comment 3 Matthew Barnes 2007-01-01 23:32:36 EST
Apologies for taking so long to reply.

Two questions:

1) Is this bug still present in Fedora Core 6 or later?

2) I have to admit that I wasn't even aware of the classification option until
   reading your bug report (it's a well hidden option).  Can you clarify for
   me what you mean when you say an appointment appears on the calendar as
   public or private?  I tried setting up both a public and private
   appointment, but they look identical to me in all of the calendar views.
   What am I missing?
Comment 4 Per Nystrom 2007-01-02 11:51:48 EST
1. It seems to have been fixed sometime during FC5's cycle.  It's definitely not
present in FC6.

2. The difference is how the appointment looks to others who have permissions on
your calendar on the Exchange server.

Comment 5 Matthew Barnes 2007-01-02 12:37:03 EST
Thanks for responding, and for enlightening me.

Closing per comment #4.  Feel free to re-open this if you encounter the problem
again in Fedora Core 6 or later.

Note You need to log in before you can comment on or make changes to this bug.