Bug 194106 - Crash on writer start, pspfontcache read doesn't match write
Crash on writer start, pspfontcache read doesn't match write
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 194003 194044 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-05 16:12 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.3-5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 15:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2006-06-05 16:12:01 EDT
Description of problem:

Crash on writer start

Version-Release number of selected component (if applicable):


openoffice.org-calc-2.0.3-5.1
openoffice.org-core-2.0.3-5.1
openoffice.org-math-2.0.3-5.1
openoffice.org-graphicfilter-2.0.3-5.1
openoffice.org-writer-2.0.3-5.1
openoffice.org-xsltfilter-2.0.3-5.1
openoffice.org-draw-2.0.3-5.1
openoffice.org-langpack-ru-2.0.3-5.1
openoffice.org-impress-2.0.3-5.1
openoffice.org-langpack-fr-2.0.3-5.1
openoffice.org-langpack-es-2.0.3-5.1

How reproducible:

Always

Steps to Reproduce:

Launch writer

Actual results:

(I) x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
(III) Desktop is: GNOME
(IV) libgcj version is: libgcj-4.1.1-1-x86_64libgcj-4.1.1-1-i386
(V) kernel is: Linux 2.6.16-1.2245_FC6 #1 SMP Sun Jun 4 19:41:53 EDT 2006 x86_64
x86_64 x86_64
(VI) OpenOffice.org core rpm version is: openoffice.org-core-2.0.3-5.1-i386
(VII) accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x7fd898: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e898
0x7fe0d8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f0d8
0xffffe500:  + 0x500 (__kernel_sigreturn + 0x0)
0x5453c0c: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x27c0c
0x545cffd: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x30ffd
(psp::FontCache::read() + 0x7ff)
0x545d2b9: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x312b9
(psp::FontCache::FontCache() + 0x69)
0x544c040: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x20040
(psp::PrintFontManager::initialize(void*) + 0x34)
0x544d105: /usr/lib/openoffice.org2.0/program/libpsp680li.so + 0x21105
(psp::PrintFontManager::get() + 0x51)
0xf7171dde: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x29dde
0xf7174be8: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x2cbe8
0x58168c4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8b8c4
(Application::MergeSystemSettings(AllSettings&) + 0x4c)
0x623c56a: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x28956a
(SvtTabAppearanceCfg::SetApplicationDefaults(Application*) + 0x172)
0x664fd19: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x25d19
(desktop::Desktop::Main() + 0x126b)
0x581aa7e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8fa7e
0x581ab31: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8fb31 (SVMain()
+ 0x2b)
0x664a299: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20299 (sal_main
+ 0x5d)
0x664a2e5: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x202e5 (main + 0x27)
0xf7e85794: /lib/libc.so.6 + 0x15794 (__libc_start_main + 0xdc)
0x80484d1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4d1
Comment 1 Caolan McNamara 2006-06-06 04:37:17 EDT
I know, it's because I'm an idiot. Fixed in 2.0.3-5.2
Comment 2 Caolan McNamara 2006-06-06 04:37:46 EDT
*** Bug 194044 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2006-06-06 04:38:40 EDT
*** Bug 194003 has been marked as a duplicate of this bug. ***
Comment 4 Paul F. Johnson 2006-06-06 04:55:38 EDT
I blame beer and hot bank holidays...
Comment 5 Caolan McNamara 2006-06-06 05:27:41 EDT
I foolishly pushed an update blindly while jetlagged at the Red Hat Summit :-(

Next update will fix, but you should be able to do something like
rm ~/.openoffice.org2.0/user/psprint/pspfontcache
touch ~/.openoffice.org2.0/user/psprint/pspfontcache
chmod agu-w ~/.openoffice.org2.0/user/psprint/pspfontcache
to workaround this until then

Note You need to log in before you can comment on or make changes to this bug.