Bug 1941159 - plans for EPEL 8
Summary: plans for EPEL 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pmount
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-20 13:57 UTC by Andrew Bauer
Modified: 2021-04-12 16:07 UTC (History)
3 users (show)

Fixed In Version: pmount-0.9.23-19.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-12 16:07:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrew Bauer 2021-03-20 13:57:31 UTC
Hey Richard - I am tidying up some loose ends to make mythtv installable on el8:

>Error: 
> Problem: package mythtv-31.0-15.139.20210226gitb6ddf202a4.el8.x86_64 requires mythplugins(x86-64) = 31.0-15.139.20210226gitb6ddf202a4.el8, but none of the providers can be installed
>  - package mythplugins-31.0-15.139.20210226gitb6ddf202a4.el8.x86_64 requires mytharchive(x86-64) = >31.0-15.139.20210226gitb6ddf202a4.el8, but none of the providers can be installed
>  - conflicting requests
>  - nothing provides dvdauthor(x86-64) >= 0.6.11 needed by mytharchive-31.0-15.139.20210226gitb6ddf202a4.el8.x86_64
>  - nothing provides pmount(x86-64) needed by mytharchive-31.0-15.139.20210226gitb6ddf202a4.el8.x86_64
>(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Can you build pmount for el8 please?

I know you are trying to lighten your workload. If you grant me commit access, I'll be glad to do all the work. 

My FAS account: kni

Comment 1 Richard Shaw 2021-03-22 14:16:47 UTC
I've added you to the epel branches (hopefully correctly).

Comment 2 Andrew Bauer 2021-03-22 14:25:34 UTC
Thank you. 

Epel8 branch requested:
https://pagure.io/releng/fedora-scm-requests/issue/33101

Comment 3 Andrew Bauer 2021-03-22 17:13:02 UTC
epel8 branch created, pmount has been built:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1726469

However, bodhi complains I don't have commit access to push the update. I've tried using fedpkg and through the bodhi web portal. Both fail.


I guess my "collaborator" access is insufficient?
Seems kind of strange I can build the package but not push it as an update.

Comment 4 Richard Shaw 2021-03-22 17:15:46 UTC
That seems wrong. Unfortunately I removed myself from the package so you'll have to reach out to hubbitus.

Comment 5 Andrew Bauer 2021-03-22 18:14:49 UTC
Confirmed on devel list that collaborator cannot push updates with today's version of Bodhi:
https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/U7GURQ6SHTDGCRSWIX4V5S2APAI6FNDF/

Well that sucks.

@hubbitus - Would you be willing to bump my permission level? Either that or push my epel8 build to Bodhi? Sorry for the trouble.

Comment 6 Andrew Bauer 2021-03-27 12:22:05 UTC
re-opening since this is unresolved and waiting for a response from the current package maintainer...

Comment 7 Pavel Alexeev 2021-03-27 13:24:34 UTC
Hello, Andrew Bauer.

Sorry for the miss that. Sure I want to give you commit rights. Could you please say your account name?

Comment 8 Andrew Bauer 2021-03-27 13:26:12 UTC
Thank you. My FAS account is kni.

I'll be glad to manage the EPEL branch for you if you are willing (you can add my contact to the overview page).

Comment 9 Pavel Alexeev 2021-03-28 12:26:18 UTC
Andrew, I've added you to the project with commit rights. Please check.

Comment 10 Fedora Update System 2021-03-28 18:56:54 UTC
FEDORA-EPEL-2021-22ea715f11 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-22ea715f11

Comment 11 Fedora Update System 2021-03-29 01:24:12 UTC
FEDORA-EPEL-2021-22ea715f11 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-22ea715f11

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-04-12 16:07:31 UTC
FEDORA-EPEL-2021-22ea715f11 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.