Bug 194143 - horizontal ghosting with Metacity AIGLX compositing
horizontal ghosting with Metacity AIGLX compositing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-05 18:40 EDT by Ben Liblit
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 22:56:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test image: four crosses on white background, no antialiasing (251 bytes, image/png)
2006-06-05 18:41 EDT, Ben Liblit
no flags Details
buggy result, magnified; note ghosting to the right of each cross (536 bytes, image/png)
2006-06-05 18:41 EDT, Ben Liblit
no flags Details

  None (edit)
Description Ben Liblit 2006-06-05 18:40:04 EDT
Description of problem:

When AIGLX and Metacity compositing are enabled, I'm seeing a slight horizontal
ghosting in all color channels.  Assuming a white background, any non-white
pixel is slightly faded out, and a very pale "ghost" of that pixel appears
offset one pixel to the right of the original.

The impression is as though the screen pixel grid were slightly offset from the
pixels that are to be displayed, so that what I'm actually seeing is the effect
of some kind of anti-aliasing.  What should be crisp vertical lines end up being
a bit blurred.  The entire screen therefore ends up looking a bit fuzzy.  This
is especially noticeable with text, though it affects *all* pixels, not just
painted text.

This is difficult to describe; I'll attach some test images that should make the
problem more clear.

Version-Release number of selected component (if applicable):

System is Fedora Core 5 with serveral components installed from the FC5 AIGLX
RPM repository, including:

    libXcomposite-0.3-4
    libdrm-2.0.1-2
    mesa-*-6.5-5
    metacity-2.15.0-6
    xorg-x11-drv-i810-1.6.0-2
    xorg-x11-server-Xorg-1.0.99.901-3

How reproducible:

Consistently occurs at all times when Metacity compositing manager is enabled
(gconf "/apps/metacity/general/compositing_manager" set to true).  Does not
occur if Metacity compositing manager is disabled.

Steps to Reproduce:
1. Start up your favorite drawing program, such as The GIMP.
2. Paint a single black pixel on a white background.
3. Use "xmag" to zoom in on that black pixel.
4. Examine the color of the black pixel as well as the pixel just to it right.
  
Actual results:

The single black pixel on a white background appears as color #202020.  The
pixel immediately to the right has color ##dfdfdf.

Expected results:

The single black pixel should have color #000000.  The pixel immediately to the
right has color ##ffffff.

Additional info:

Hardware is a ThinkPad X40 with Intel 82852/855GM Integrated Graphics Device.
Comment 1 Ben Liblit 2006-06-05 18:41:01 EDT
Created attachment 130549 [details]
test image: four crosses on white background, no antialiasing
Comment 2 Ben Liblit 2006-06-05 18:41:49 EDT
Created attachment 130550 [details]
buggy result, magnified; note ghosting to the right of each cross
Comment 3 Matthias Clasen 2006-08-14 22:56:47 EDT
Closing bugs related to the metacity compositor, since we no longer develop it.

Note You need to log in before you can comment on or make changes to this bug.