Bug 194236 - FutureFeature: Include ndiswrapper into Core
Summary: FutureFeature: Include ndiswrapper into Core
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-06 14:48 UTC by Mark Bidewell
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 04:29:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Bidewell 2006-06-06 14:48:51 UTC
The inclusion of ndiswrapper into Core would ease the process of installing
wireless cards into fedora.  as things stand now, a PC must first be connected
to a wired connection and ndiswrapper and its dependencies must be downloaded
before it can be used. Having this available from install would be a great
convienience for users using wireless cards not well supported natively.  I do
not believe that inclusion would violate the FOSS Fedora policy since drivers
would not be included and ndiswrapper is itself FOSS.

Comment 1 Dan Williams 2006-07-09 23:52:30 UTC
Over to the kernel guys, but this is likely going to be rejected unless
ndiswrapper gets upstream into the kernel; Fedora tracks the upstream kernel
quite closely and getting a kernel feature/driver into Fedora usually requires
that it be upstream in Linus' kernel first.

Comment 2 Dave Jones 2006-07-13 04:29:19 UTC
No chance.  This is no different to any other binary module. Once it's used,
debugging any kernel problem becomes a nightmare, as you have *no* idea what the
foreign code has been doing.



Note You need to log in before you can comment on or make changes to this bug.