Bug 194284 - latest evolution dependency issue
latest evolution dependency issue
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-06 16:37 EDT by Piergiorgio Sartor
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-31 21:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2006-06-06 16:37:07 EDT
Description of problem:
Well, it quite simple, latest evolution update requires, for
unknown reasons, "NetworkManager-glib".
This one pulls in a lot of other packages, which are not always
quite useful, like "wpa_supplicant" or "dhcdb".

I checked the evolution homepage and the rpm changelog, and I found
no reference to "NetworkManager-glib", so I was wondering if this is
really a necessary dependency or slipped in by mistake.

The issue is that things like "wpa_supplicant" will be disabled
(on my system, and, I guess, on many others), so the dependency
from "NetworkManager", which comes from "NetworkManager-glib",
is useless, unless the service is enabled.

This lead to think that the dependency chain should be reconsidered,
also in order to avoid junk packages around the system.

Thanks.

Version-Release number of selected component (if applicable):
2.6.2-1.fc5.1
Comment 1 Matthew Barnes 2006-12-31 21:52:12 EST
Evolution uses NetworkManager to detect when to switch to offline mode.

Note You need to log in before you can comment on or make changes to this bug.