Bug 194323 - %post in gnome-themes cannot handle themes with spaces.
Summary: %post in gnome-themes cannot handle themes with spaces.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-themes   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-07 10:59 UTC by Timothy Hinchcliffe
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.14.2-1.fc5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-12 08:28:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Timothy Hinchcliffe 2006-06-07 10:59:57 UTC
Description of problem:
If installing or updating gnome-themes with a theme with a space in the
directory name already installed, an errors such as:
 No theme index file in '/usr/share/icons/Crystal'.
 If you really want to create an icon cache here, use --ignore-theme-index.
is reported.

Version-Release number of selected component (if applicable):
2.14.2-1

How reproducible:
Every time.

Steps to Reproduce:
1. Install a theme such as Crystal Clear (http://linuxcult.com/node/10) for KDE.
2. rpm -e gnome-themes --nodeps
3. yum -y install gnome-themes
  
Actual results:
.
:
Running Transaction
  Installing: gnome-themes                 ######################### [1/1]
No theme index file in '/usr/share/icons/Crystal'.
If you really want to create an icon cache here, use --ignore-theme-index.

Installed: gnome-themes.noarch 0:2.14.2-1
Complete!


Expected results:
.
:
Running Transaction
  Installing: gnome-themes                 ######################### [1/1]

Installed: gnome-themes.noarch 0:2.14.2-1
Complete!

Additional info:
The %post script reads:
postinstall scriptlet (using /bin/sh):
for dir in /usr/share/icons/*; do
  if test -d "$dir"; then
    if test -f "$dir/index.theme"; then
      /usr/bin/gtk-update-icon-cache --quiet $dir
    fi
  fi
done

The gtk-update-icon-cache line should read:
      /usr/bin/gtk-update-icon-cache --quiet "$dir"

The other lines are already quoted so do not suffer this problem.

Comment 1 Timothy Hinchcliffe 2006-06-07 11:11:09 UTC
The same problem also effects gnome-icon-theme (see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=194324 )

Comment 2 Fedora Update System 2006-06-07 23:41:31 UTC
gnome-themes-2.14.2-1.fc5.1 gnome-icon-theme-2.14.2-1.fc5.1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 3 Fedora Update System 2006-06-14 18:04:41 UTC
gnome-themes-2.14.2-1.fc5.1 gnome-icon-theme-2.14.2-1.fc5.1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 4 Timothy Hinchcliffe 2006-06-15 09:24:33 UTC
gnome-themes worked correctly.
gnome-icon-theme was already at version 2.14.2-1.fc5.1 (Since June 7th 2006) so
did not upgrade!

Comment 5 Fedora Update System 2006-08-02 20:43:40 UTC
gnome-icon-theme-2.14.2-1.fc5.2 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.