Bug 194409 - KDE: Can't use the Windows Key in a shortcut anymore
KDE: Can't use the Windows Key in a shortcut anymore
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdeaccessibility (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-07 16:57 EDT by Scott Baker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 17:35:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Baker 2006-06-07 16:57:16 EDT
Description of problem:
Cannot create a new shortcut key using the Windows key.

How reproducible:
Easy

Steps to Reproduce:
1. Go to the KDE menu and select any program
2. Right click "edit item"
3. Click "current shortcut key" and try and assign it to anything using the
Windows key.
  
Actual results:
Win + D ends up as "D" when you're done. 

Expected results:
The shortcut should be the key combo I entered Win + D

Additional info:
I can create shortcuts using ctrl/alt/shift (or a combination of those) no
problem. It's *just* the Windows key that doesn't work. KDE recognizes that I'm
pressing the Windows key as it says "Win +" before I hit the D. But as soon as I
hit "D" it just saves the "D" as the shortcut.

There are a couple places you can edit shortcuts throughout KDE, and they all
exhibit the same behaviour. I've tried on three KDE installs all FC5 with the
latest "yum upgrade."
Comment 1 Ngo Than 2006-06-07 17:29:12 EDT
which version of kdelibs/kdebase/kdeaddons are installed on your machine?
Comment 2 Scott Baker 2006-06-07 17:41:32 EDT
[bakers@snikt ~]$ rpm -qa | grep -E "kde(libs|base|addons)"
kdebase-3.5.2-0.5.fc5
kdeaddons-3.5.2-0.1.fc5
kdelibs-3.5.2-0.2.fc5
Comment 3 Scott Baker 2006-06-08 13:29:52 EDT
After a reboot I can assign that key again. It seems to me that KDE "forgets"
the Windows key after a while. I'll keep an eye on it and see when it breaks
again. I've recreated it on three machines, I just need to figure out how to
cause KDE to break.

Perhaps it's a Kernel thing? I'm trying a new kernel in updates-testing maybe
that will affect things. Are you able to recreate it?

[bakers@snikt ~]$ uname -r
2.6.16-1.2129_FC5
Comment 4 Ngo Than 2006-06-08 17:35:47 EDT
with your steps above, i cannot reproduce this problem on 2 test machines with 
FC5+updates! It just works for me.

Please reopen it if you can reproduce this problem again. Thanks
Comment 5 Scott Baker 2006-06-23 12:12:10 EDT
Can we reopen this? I can't force the issue to come up, but I can recreate it.
The easiest way is to create a shortcut that uses it. For example I bind Win + E
to launch konqueror. I use this all the time. After some random amount of time
the shortcut stops working. Pressing Win + E just enters "e" into whatever
application has the focus. It happens all the time, it's just a matter or
waiting. It's never taken longer than 2 days to crop back up. A restart of KDE
fixes the problem.
Comment 6 Ngo Than 2006-06-23 12:29:50 EDT
could you please try new KDE-3.5.3 in FC5 update? does the issue still
appear?
Comment 7 Scott Baker 2006-06-23 12:52:16 EDT
The problem does occur with the latest KDE. I restarted X this morning probably
an hour ago. And my shortcut worked after the restart, but now it's broken
again. It took less than an hour to "break." It's hard to track down, I'm
wondering if it has something to do with either XScreenSaver or me locking my
work station? I'll do some more digging.
Comment 8 Scott Baker 2006-06-23 13:02:23 EDT
Checking xev while it's broken/fixed doesn't yield any differences. Unless you
read this differently.

-----------------------------------------------------------------------

Broken:

KeyPress event, serial 32, synthetic NO, window 0x2800001,
    root 0x5c, subw 0x0, time 30700130, (103,-8), root:(927,139),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 32, synthetic NO, window 0x2800001,
    root 0x5c, subw 0x0, time 30700855, (103,-8), root:(927,139),
    state 0x0, keycode 40 (keysym 0x64, d), same_screen YES,
    XLookupString gives 1 bytes: (64) "d"
    XmbLookupString gives 1 bytes: (64) "d"
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x2800001,
    root 0x5c, subw 0x0, time 30700948, (103,-8), root:(927,139),
    state 0x0, keycode 40 (keysym 0x64, d), same_screen YES,
    XLookupString gives 1 bytes: (64) "d"

KeyRelease event, serial 32, synthetic NO, window 0x2800001,
    root 0x5c, subw 0x0, time 30701094, (103,-8), root:(927,139),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:

---------------------------------------------------------------------------
Works (After restarting X):

KeyPress event, serial 28, synthetic NO, window 0x2200001,
    root 0x5c, subw 0x0, time 30990460, (-510,456), root:(470,480),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 31, synthetic NO, window 0x2200001,
    root 0x5c, subw 0x0, time 30990614, (-510,456), root:(470,480),
    state 0x40, keycode 42 (keysym 0x67, g), same_screen YES,
    XLookupString gives 1 bytes: (67) "g"
    XmbLookupString gives 1 bytes: (67) "g"
    XFilterEvent returns: False

KeyRelease event, serial 31, synthetic NO, window 0x2200001,
    root 0x5c, subw 0x0, time 30990679, (-510,456), root:(470,480),
    state 0x40, keycode 42 (keysym 0x67, g), same_screen YES,
    XLookupString gives 1 bytes: (67) "g"

KeyRelease event, serial 31, synthetic NO, window 0x2200001,
    root 0x5c, subw 0x0, time 30990827, (-510,456), root:(470,480),
    state 0x40, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:

Note You need to log in before you can comment on or make changes to this bug.