Bug 194429 - Class Names on Reference, ReferenceNames, Assoc, AssocNames returned lower case
Class Names on Reference, ReferenceNames, Assoc, AssocNames returned lower case
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-07 19:54 EDT by Dave Sudlik
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.5.1-2.EL4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 12:13:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Sudlik 2006-06-07 19:54:40 EDT
Description of problem:

This is a pointer to OpenPegasus bug 5073.

Effective with pegasus 2.5.1, the classnames on references, referenceNames,
associators, associatorNames operations are all returned lower
case.   This was apparently an artifact of bug 3241, the performance improvement
for associations, and was not caught because the tests are all primarily
concerned with determining if we are returning the proper number of objects, not
the exact form of the objects.  Thus they did not catch the fact that in 2.5.0
the case of returned names was correct and in 2.5.1, it was forced to lower case.

Version-Release number of selected component (if applicable):
tog-pegasus-2.5.1-1.EL4

How reproducible:
CIM Client calls to affects CIM operations.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

This is a partial return from 2.5.1 for the command  cli rn CIM_ManagedElement:

//emily2/root/cimv2:cim_affectedjobelement
//emily2/root/cimv2:cim_recordappliestoelement
//emily2/root/cimv2:cim_availablediagnosticservice
//emily2/root/cimv2:cim_elementconformstoprofile
//emily2/root/cimv2:cim_memberprincipal
//emily2/root/cimv2:cim_identitycontext
//emily2/root/cimv2:cim_assignedidentity
//emily2/root/cimv2:cim_elementsecuritysensitivity
//emily2/root/cimv2:cim_authenticationtarget
//emily2/root/cimv2:cim_elementasuser
//emily2/root/cimv2:cim_authorizedsubject
//emily2/root/cimv2:cim_authorizedtarget
//emily2/root/cimv2:cim_authorizationsubject
//emily2/root/cimv2:cim_authorizationtarget
//emily2/root/cimv2:cim_metricdefforme
//emily2/root/cimv2:cim_metricforme
//emily2/root/cimv2:cim_storagesynchronized
//emily2/root/cimv2:cim_elementinpolicyrolecollection
//emily2/root/cimv2:cim_policysetappliestoelement

Expected results:

This is a partial return from 2.5.0 for the command  cli rn CIM_ManagedElement:

//emily2/root/cimv2:CIM_ElementConformsToProfile
//emily2/root/cimv2:CIM_MemberPrincipal
//emily2/root/cimv2:CIM_IdentityContext
//emily2/root/cimv2:CIM_AssignedIdentity
//emily2/root/cimv2:CIM_ElementSecuritySensitivity
//emily2/root/cimv2:CIM_AuthenticationTarget
//emily2/root/cimv2:CIM_ElementAsUser
//emily2/root/cimv2:CIM_AuthorizedSubject
//emily2/root/cimv2:CIM_AuthorizedTarget
//emily2/root/cimv2:CIM_AuthorizationSubject
//emily2/root/cimv2:CIM_AuthorizationTarget
//emily2/root/cimv2:CIM_MetricDefForME
//emily2/root/cimv2:CIM_MetricForME
//emily2/root/cimv2:CIM_StorageSynchronized
//emily2/root/cimv2:CIM_ElementInPolicyRoleCollection
//emily2/root/cimv2:CIM_PolicySetAppliesToElement

Additional info:
Comment 1 Jason Vas Dias 2006-06-14 16:59:15 EDT
fixed with tog-pegasus-2.5.1-2.EL4 (a candidate for RHEL-4 FastTrack post-U4)
and in Fedora Core 6 / rawhide with tog-pegasus-2.5.1-8.fc6.

Note You need to log in before you can comment on or make changes to this bug.