Bug 194432 - qemu spec File: Incorrect BuildRoot Tag
qemu spec File: Incorrect BuildRoot Tag
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Packagi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-07 21:45 EDT by Peter Gordon
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-21 13:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch applies to the root qemu directory in CVS and fixes the BuildRoot tags on all four branches. (2.52 KB, patch)
2006-06-07 21:45 EDT, Peter Gordon
no flags Details | Diff

  None (edit)
Description Peter Gordon 2006-06-07 21:45:03 EDT
The BuildRoot tag in qemu.spec (branches FC-3, FC-4, FC-5, and devel) is
incorrect. It is currently "%{_tmppath}/%{name}-%{version}-root" but should be
"%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)" as stated in
Packaging/Guidelines on the wiki.
Comment 1 Peter Gordon 2006-06-07 21:45:03 EDT
Created attachment 130719 [details]
This patch applies to the root qemu directory in CVS and fixes the BuildRoot tags on all four branches.
Comment 2 Peter Gordon 2006-09-07 23:52:40 EDT
Ping?

The FC-3 and FC-4 branches still need fixing to be in compliance with the Extras
Packaging Guidelines on this.

Thanks. 
Comment 3 Peter Gordon 2006-10-21 04:50:03 EDT
Er...David? What is your status on fixing these?

If I do not receive any update on this bug by Oct 22, 14:00 PDT (which gives you
more than 36 hours), I will personally commit the fixed for these into CVS.

Thanks.
Comment 4 David Woodhouse 2006-10-21 10:35:03 EDT
Sorry. Yes, please do go ahead and commit it if you have access. Why didn't you
just do that in the first place, in fact?
Comment 5 Peter Gordon 2006-10-21 13:43:43 EDT
Thanks, David. I generally like to get an OK from the primary maintainer of the
packageor know that he/she is not active before mangling with it myself.

Fixed in CVS.
Comment 6 Peter Gordon 2006-10-21 13:48:11 EDT
Closing as WORKSFORME, since no new packages were built for FC3/4, so the
CURRENTRELEASE/NEXTRELEASE options don't seem very sensible to me.
Comment 7 David Woodhouse 2006-10-21 14:05:11 EDT
Oh, I'm active, but I'm not going to be moronically territorial about it. 

It's easier for you to just do 'cvs commit' than to file a bug with the patch,
even if I'm _not_ so busy that I end up ignoring it for months at a time (for
which, sorry). And it's certainly easier for me -- it's the most sensible option
all round.

If we're talking about something that might be _contentious_, I suppose it might
be different. But this doesn't fall into that category.

Note You need to log in before you can comment on or make changes to this bug.