This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 194468 - panel crashing after gnome-panel-2.14.2-1.fc5.1 update
panel crashing after gnome-panel-2.14.2-1.fc5.1 update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-08 08:29 EDT by Steve Fox
Modified: 2008-03-18 14:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2006-06-08 08:29:14 EDT
Description of problem:
After installing all the errata as of June 7th (see below), now my panel
constantly crashes, even after a reboot.

gnome-panel-debuginfo-2.14.2-1.fc5.1          Thu 08 Jun 2006 07:27:51 AM CDT
gdm-2.14.4-1.fc5.3                            Wed 07 Jun 2006 11:28:33 PM CDT
evolution-data-server-debuginfo-1.6.2-1.fc5.1 Wed 07 Jun 2006 11:28:17 PM CDT
evolution-sharp-0.10.2-9.3                    Wed 07 Jun 2006 11:28:11 PM CDT
planner-0.13-4.4                              Wed 07 Jun 2006 11:27:56 PM CDT
gnome-panel-2.14.2-1.fc5.1                    Wed 07 Jun 2006 11:26:14 PM CDT
evolution-2.6.2-1.fc5.5                       Wed 07 Jun 2006 11:25:18 PM CDT
evolution-data-server-1.6.2-1.fc5.1           Wed 07 Jun 2006 11:24:35 PM CDT
gstreamer-plugins-base-devel-0.10.7.2-0.gst.1.5 Wed 07 Jun 2006 08:58:10 AM CDT
gstreamer-devel-0.10.6.2-0.gst.1.5            Wed 07 Jun 2006 08:58:04 AM CDT
gstreamer-plugins-base-0.10.7.2-0.gst.1.5     Wed 07 Jun 2006 08:57:02 AM CDT
gstreamer-0.10.6.2-0.gst.1.5                  Wed 07 Jun 2006 08:56:52 AM CDT
gstreamer-tools-0.10.6.2-0.gst.1.5            

Version-Release number of selected component (if applicable):

gnome-panel-2.14.2-1.fc5.1

How reproducible:

always

Steps to Reproduce:
1. login to GNOME
2. panel crashes

The only debuginfo package I have installed is for gnome-panel so let me know if
the below is useless and I can install more packages as needed.

Backtrace was generated from '/usr/bin/gnome-panel'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1208539456 (LWP 6330)]
0x0017e402 in __kernel_vsyscall ()
#0  0x0017e402 in __kernel_vsyscall ()
#1  0x0042abe3 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x00a40e26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0017e402 in __kernel_vsyscall ()
#5  0x001c4069 in raise () from /lib/libc.so.6
#6  0x001c5671 in abort () from /lib/libc.so.6
#7  0x00462c42 in g_logv () from /usr/lib/libglib-2.0.so.0
#8  0x00462c79 in g_log () from /usr/lib/libglib-2.0.so.0
#9  0x00462cf6 in g_assert_warning () from /usr/lib/libglib-2.0.so.0
#10 0x00813a70 in ORBit_RootObject_duplicate_T ()
   from /usr/lib/libORBit-2.so.0
#11 0x0081c8e8 in CORBA_any__freekids () from /usr/lib/libORBit-2.so.0
#12 0x00818a8a in CORBA_exception__copy () from /usr/lib/libORBit-2.so.0
#13 0x00818b17 in CORBA_exception_free () from /usr/lib/libORBit-2.so.0
#14 0x00818bbc in CORBA_exception_set () from /usr/lib/libORBit-2.so.0
#15 0x00818c83 in CORBA_exception_set_system () from /usr/lib/libORBit-2.so.0
#16 0x00814d9d in ORBit_small_invoke_stub () from /usr/lib/libORBit-2.so.0
#17 0x00814e8e in ORBit_small_invoke_stub_n () from /usr/lib/libORBit-2.so.0
#18 0x00822112 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#19 0x00915cde in Bonobo_Control_getProperties ()
   from /usr/lib/libbonobo-2.so.0
#20 0x00aaab9f in bonobo_control_frame_get_control_property_bag ()
   from /usr/lib/libbonoboui-2.so.0
#21 0x08086512 in panel_applet_frame_activated (object=0x8e301f8, 
    ev=0xbfb93658, data=0x8e21768) at panel-applet-frame.c:1296
#22 0x008fe8c1 in bonobo_moniker_util_parse_name ()
   from /usr/lib/libbonobo-2.so.0
#23 0x008febff in bonobo_moniker_resolve_async_default ()
   from /usr/lib/libbonobo-2.so.0
#24 0x00814041 in ORBit_small_get_connection_status ()
   from /usr/lib/libORBit-2.so.0
#25 0x0080ddf8 in giop_invoke_async () from /usr/lib/libORBit-2.so.0
#26 0x00811436 in giop_connection_handle_input ()
   from /usr/lib/libORBit-2.so.0
#27 0x0082ed8d in link_connection_state_changed ()
   from /usr/lib/libORBit-2.so.0
#28 0x00831c2e in link_io_add_watch_fd () from /usr/lib/libORBit-2.so.0
#29 0x0045a15d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0x0045d3ef in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#31 0x0045d799 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#32 0x06deb634 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#33 0x08062dc7 in main (argc=1, argv=0xbfb93984) at main.c:92

Thread 1 (Thread -1208539456 (LWP 6330)):
#0  0x0017e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0042abe3 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00a40e26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x0017e402 in __kernel_vsyscall ()
No symbol table info available.
#5  0x001c4069 in raise () from /lib/libc.so.6
No symbol table info available.
#6  0x001c5671 in abort () from /lib/libc.so.6
No symbol table info available.
#7  0x00462c42 in g_logv () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x00462c79 in g_log () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x00462cf6 in g_assert_warning () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#10 0x00813a70 in ORBit_RootObject_duplicate_T ()
   from /usr/lib/libORBit-2.so.0
No symbol table info available.
#11 0x0081c8e8 in CORBA_any__freekids () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#12 0x00818a8a in CORBA_exception__copy () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#13 0x00818b17 in CORBA_exception_free () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#14 0x00818bbc in CORBA_exception_set () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#15 0x00818c83 in CORBA_exception_set_system () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#16 0x00814d9d in ORBit_small_invoke_stub () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#17 0x00814e8e in ORBit_small_invoke_stub_n () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#18 0x00822112 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#19 0x00915cde in Bonobo_Control_getProperties ()
   from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#20 0x00aaab9f in bonobo_control_frame_get_control_property_bag ()
   from /usr/lib/libbonoboui-2.so.0
No symbol table info available.
#21 0x08086512 in panel_applet_frame_activated (object=0x8e301f8, 
    ev=0xbfb93658, data=0x8e21768) at panel-applet-frame.c:1296
	frame = (PanelAppletFrame *) 0x8e23990
	widget = (GtkWidget *) 0x8df8a98
	control_frame = (BonoboControlFrame *) 0x8e23290
	control =
Comment 1 kOoLiNuS 2006-06-22 11:59:08 EDT
I see panel crashing at least once a day, random during a work session.

I suspect that has something to do with the default battery applet (since on my
desktop machine which is "identical" in installed software" i don't use it and
do not have those crashes).

[nicola@ierofante ~]$ rpm -q gnome-panel
gnome-panel-2.14.2-1.fc5.1

hope it helps!
Comment 2 Ray Strode [halfline] 2008-03-18 14:33:21 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.