Bug 194493 - "sfdisk -l" doesn't ignore partitions
"sfdisk -l" doesn't ignore partitions
Status: CLOSED DUPLICATE of bug 188981
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-08 11:00 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 15:30:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
util-linux-sfdisk-dont-open-partitions.patch (3.13 KB, patch)
2006-06-08 11:00 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-06-08 11:00:15 EDT
util-linux-2.12a-16.EL4.16

But "fdisk -l" ignores them.

$ fdisk -l

Disk /dev/sda: 36.4 GB, 36420075008 bytes
255 heads, 63 sectors/track, 4427 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14         650     5116702+  83  Linux
/dev/sda3             651         777     1020127+  82  Linux swap
/dev/sda4             778        4427    29318625    f  W95 Ext'd (LBA)
/dev/sda5             778        4427    29318593+  83  Linux

$ sfdisk -l

Disk /dev/sda: 4427 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1   *      0+     12      13-    104391   83  Linux
/dev/sda2         13     649     637    5116702+  83  Linux
/dev/sda3        650     776     127    1020127+  82  Linux swap
/dev/sda4        777    4426    3650   29318625    f  W95 Ext'd (LBA)
/dev/sda5        777+   4426    3650-  29318593+  83  Linux
Warning: start=63 - this looks like a partition rather than
the entire disk. Using fdisk on it is probably meaningless.
[Use the --force option if you really want this]

Patch attached fixes the above error message.
Comment 1 Bastien Nocera 2006-06-08 11:00:15 EDT
Created attachment 130753 [details]
util-linux-sfdisk-dont-open-partitions.patch
Comment 2 Karel Zak 2006-06-08 15:30:10 EDT

*** This bug has been marked as a duplicate of 188981 ***

Note You need to log in before you can comment on or make changes to this bug.