Bug 194545 - Yum Error - header not complete
Yum Error - header not complete
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-08 17:05 EDT by Donald Hudock
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 16:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Hudock 2006-06-08 17:05:13 EDT
Description of problem: Yum or Yumex produces the error "header not complete"
and keeps trying to download the entire .rpm over and over, until there are no
more repositories.  Can not update any application.  I have used all 3 clear
commnads.  I can download an .rpm and update using the RPM command.


Version-Release number of selected component (if applicable): 2.6.0


How reproducible: every time


Steps to Reproduce:
1. yum -y update
2.
3.
  
Actual results:
# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core [1/6]
core 100% |=========================| 1.1 kB 00:00
dries [2/6]
dries 100% |=========================| 951 B 00:00
macromedia [3/6]
macromedia 100% |=========================| 951 B 00:00
updates [4/6]
updates 100% |=========================| 951 B 00:00
freshrpms [5/6]
freshrpms 100% |=========================| 951 B 00:00
extras [6/6]
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 767 kB 00:30
core : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 15.63 seconds
primary.xml.gz 100% |=========================| 691 kB 00:16
dries : ################################################## 2888/2888
Added 2888 new packages, deleted 0 old in 15.36 seconds
primary.xml.gz 100% |=========================| 1.1 kB 00:00
macromedia: ################################# 2/3Added 2 new packages, deleted 0
old in 0.09 seconds
primary.xml.gz 100% |=========================| 377 kB 00:08
updates : ################################################## 1164/1164
Added 1164 new packages, deleted 0 old in 10.55 seconds
primary.xml.gz 100% |=========================| 56 kB 00:01
freshrpms : ################################################## 180/180
Added 180 new packages, deleted 0 old in 1.40 seconds
primary.xml.gz 100% |=========================| 943 kB 00:25
extras : ################################################## 3557/3557
Added 3557 new packages, deleted 0 old in 24.66 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for ghostscript to pack into transaction set.
ghostscript-8.15.2-1.1.i3 100% |=========================| 8.6 MB 01:07
http://mirror.eas.muohio.edu/fedora...2-1.1.i386.rpm: [Errno -1] Header is not
complete.
Trying other mirror.


Expected results: expect it to work


Additional info:
Comment 1 Donald Hudock 2006-06-08 17:07:19 EDT
I have tried to update individual packages using yum and yumex with the same
results.
Comment 2 Jeremy Katz 2006-09-18 16:47:38 EDT
Are you still seeing this?
Comment 3 Donald Hudock 2006-09-18 16:59:46 EDT
This problem has been solved.  This error is caused by having Virus and Spyware
detection enabled on a SonicWall router.  I am using a SonicWall Pro 2040 with
Enhanced Firmware.  Other people that have had this error were also using
SonicWall routers and disabling Anti-Virus / Spyware detection has solved thier
issue as well.

Thanks for the followup.

Note You need to log in before you can comment on or make changes to this bug.