Bug 194561 - Upgrade of scim-libs fails on postinstall scriptlet
Upgrade of scim-libs fails on postinstall scriptlet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 194587 195444 195445 195447 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-13 23:51 EDT by Mamoru TASAKA
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.4-9.4.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 00:14:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2006-06-13 23:51:06 EDT
Description of problem:
The newest upgrade of scim-libs (1.4.4-9.2.fc5) fails on postinstall
scriptlet. As a result, the old version of scim-libs is not deleted.

Version-Release number of selected component (if applicable):
scim-libs-1.4.4-9.3.fc5

How reproducible:
100%

Steps to Reproduce:
1. Upgrade scim-libs to scim-libs-1.4.4-9.3.fc5
2.
3.
  
Actual results:
Upgrading scim-libs fails on postinstall scriptlet by this command:
[root@localhost ~]# /usr/bin/update-gtk-immodules i386-redhat-linux-gnu
Cannot load module /usr/lib/gtk-2.0/immodules/im-scim.so:
/usr/lib/libscim-x11utils-1.0.so.8: undefined symbol:
_ZNSt11_7_200604288ios_base4InitC1Ev
/usr/lib/gtk-2.0/immodules/im-scim.so does not export GTK+ IM module API:
/usr/lib/libscim-x11utils-1.0.so.8: undefined symbol:
_ZNSt11_7_200604288ios_base4InitC1Ev

As a result, the old version of scim-libs is not deleted:
[root@localhost ~]# rpm -q scim-libs
scim-libs-1.4.4-9.2.fc5
scim-libs-1.4.4-9.3.fc5

Expected results:
Upgrading scim-libs should succeed.

Additional info:
This is the re-submittance of bug 194953, which seems to have disappeared 
because of bugzilla corruption.
Comment 1 Mamoru TASAKA 2006-06-14 00:14:20 EDT
Okay, I missed the annoucement of releasing scim-1.4.4-9.4.fc5. This package
fixed this issue.

Thanks.
Comment 2 Jens Petersen 2006-06-14 04:46:15 EDT
Thank you for confirming the fixed package so quickly.
Comment 3 Jens Petersen 2006-06-14 04:57:37 EDT
*** Bug 194587 has been marked as a duplicate of this bug. ***
Comment 4 Jens Petersen 2006-07-05 06:47:35 EDT
*** Bug 195444 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2006-07-05 06:48:41 EDT
*** Bug 195447 has been marked as a duplicate of this bug. ***
Comment 6 Jens Petersen 2006-07-05 06:49:31 EDT
*** Bug 195445 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.