Bug 19458 - segfault on maximize window
Summary: segfault on maximize window
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slang   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-20 12:22 UTC by Harald Hoyer
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-20 12:22:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Harald Hoyer 2000-10-20 12:22:35 UTC
If I switch from  maximize my rxvt from rows 24; columns 80;  to rows 86;
columns 262; mutt segfaults :)

(gdb) bt
#0  0x5 in ?? ()
#1  0x4004f251 in SLcurses_wrefresh () from /usr/lib/libslang.so.1
#2  0x8058500 in strcpy () at ../sysdeps/generic/strcpy.c:31
#3  0x8059e42 in strcpy () at ../sysdeps/generic/strcpy.c:31
#4  0x806cdfc in strcpy () at ../sysdeps/generic/strcpy.c:31
#5  0x40234e21 in __libc_start_main (main=0x806c210 <strcpy+132976>,
argc=1, 
    ubp_av=0xbffffb24, init=0x804acc0 <_init>, fini=0x80a340c <_fini>, 
    rtld_fini=0x4000df94 <_dl_fini>, stack_end=0xbffffb1c)
    at ../sysdeps/generic/libc-start.c:111

Comment 1 Bill Nottingham 2001-01-29 18:47:32 UTC
I can't reproduce this in the beta - it resizes from 80x26 to 248x118 correctly.


Note You need to log in before you can comment on or make changes to this bug.