Bug 1946134 - Liferea's Feed Title Bar affected after webkit2gtk3 update
Summary: Liferea's Feed Title Bar affected after webkit2gtk3 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liferea
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-04 22:18 UTC by Jorge Fábregas
Modified: 2021-04-24 20:09 UTC (History)
11 users (show)

Fixed In Version: liferea-1.13.5-2.fc33 liferea-1.13.5-3.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-19 17:45:16 UTC
Type: Bug


Attachments (Terms of Use)
Before webkit2gtk3 update (135.97 KB, image/png)
2021-04-04 22:18 UTC, Jorge Fábregas
no flags Details
After webkit2gtk3 update (140.35 KB, image/png)
2021-04-04 22:19 UTC, Jorge Fábregas
no flags Details

Description Jorge Fábregas 2021-04-04 22:18:58 UTC
Created attachment 1769132 [details]
Before webkit2gtk3 update

Description of problem: After updating to webkit2gtk3-2.32.0-1.fc33.x86_64, liferea's Title-Bar is affected (not showing bar as it should).  Please see attached screenshots of before & after the update.


Version-Release number of selected component (if applicable):
webkit2gtk3-2.32.0-1.fc33.x86_64
liferea-1.13.4-1.fc33.x86_64


How reproducible:
always


Steps to Reproduce:
1. intall liferea & step into one fee item (look at its title-bar)
2. update to webkit2gtk3-2.32.0-1.fc33.x86_64


Actual results:
favicon & title-bar disappears

Expected results:
normal title-bar layout shouuld render

Comment 1 Jorge Fábregas 2021-04-04 22:19:49 UTC
Created attachment 1769133 [details]
After webkit2gtk3 update

Comment 2 Michael Catanzaro 2021-04-05 13:58:46 UTC
Hi, since this is not a packaging issue, please feel free to report it on WebKit Bugzilla, WebKitGTK component. Thanks!

Comment 3 Fabrice Bellet 2021-04-05 16:46:59 UTC
Maybe the packager could cherry-pick for commit from this issue, until its merged upstream:
https://github.com/lwindolf/liferea/issues/973

Comment 4 Fabrice Bellet 2021-04-05 16:50:50 UTC
Reassigning to liferea, and reopening.

Comment 5 Emmanuel Seyman 2021-04-05 21:35:33 UTC
I can confirm that the problem exists and that the PR that Fabrice points out fixes the issue. I'll issue an update tomorrow.

Comment 6 Fedora Update System 2021-04-12 09:44:56 UTC
FEDORA-2021-5f8586bd8b has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5f8586bd8b

Comment 7 Fedora Update System 2021-04-12 09:44:57 UTC
FEDORA-2021-c664718ef1 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-c664718ef1

Comment 8 Fedora Update System 2021-04-12 15:10:02 UTC
FEDORA-2021-c664718ef1 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-c664718ef1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-c664718ef1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-04-12 16:42:43 UTC
FEDORA-2021-5f8586bd8b has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5f8586bd8b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5f8586bd8b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-04-19 17:45:16 UTC
FEDORA-2021-5f8586bd8b has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2021-04-24 20:09:45 UTC
FEDORA-2021-c664718ef1 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.