Bug 195209 - pls help... yum not working
pls help... yum not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 11:10 EDT by Kiran Kumar
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 00:01:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the report (3.63 KB, application/octet-stream)
2006-06-14 11:10 EDT, Kiran Kumar
no flags Details

  None (edit)
Description Kiran Kumar 2006-06-14 11:10:22 EDT
Description of problem:

yum command is not working


Actual results:
get the following whenever i run yum

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 80, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
    self.doConfigSetup(fn=opts.conffile, root=root)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 104, in
doConfigSetup
    self.getReposFromConfig()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 135, in
getReposFromConfig
    parser.read(files)
  File "/usr/lib/python2.4/site-packages/yum/parser.py", line 225, in read
    IncludingConfigParser.read(self,filename)
  File "/usr/lib/python2.4/site-packages/yum/parser.py", line 126, in read
    ConfigParser.read(self,filename)
  File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
    self._read(fp, filename)
  File "/usr/lib/python2.4/ConfigParser.py", line 462, in _read
    raise MissingSectionHeaderError(fpname, lineno, line)
ConfigParser.MissingSectionHeaderError: File contains no section headers.
file: ///etc/yum.repos.d/fedora-updates.repo, line: 1
'\xed\xab\xee\xdb\x03\x00\x00\x00\x00\x01flash-plugin-7.0.63-1\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x01\x00\x05\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x8e\xad\xe8\x01\x00\x00\x00\x00\x00\x00\x00\x07\x00\x00\x00\xd8\x00\x00\x00>\x00\x00\x00\x07\x00\x00\x00\xc8\x00\x00\x00\x10\x00\x00\x01\x0b\x00\x00\x00\x07\x00\x00\x00\x00\x00\x00\x00A\x00\x00\x01\r\x00\x00\x00\x06\x00\x00\x00A\x00\x00\x00\x01\x00\x00\x03\xe8\x00\x00\x00\x04\x00\x00\x00l\x00\x00\x00\x01\x00\x00\x03\xec\x00\x00\x00\x07\x00\x00\x00p\x00\x00\x00\x10\x00\x00\x03\xed\x00\x00\x00\x07\x00\x00\x00\x80\x00\x00\x00A\x00\x00\x03\xef\x00\x00\x00\x04\x00\x00\x00\xc4\x00\x00\x00\x01\x88?\x03\x05\x00D\x183`)\xd5\xba$\x8d\xf5m\x05\x11\x02p\xe5\x00\x9c\n'


Expected results: package shd get installed


Additional info:
Comment 1 Kiran Kumar 2006-06-14 11:10:23 EDT
Created attachment 130862 [details]
the report
Comment 2 Seth Vidal 2006-07-10 00:01:06 EDT
Looks like you have a corrupted configuration file:
/etc/yum.repos.d/fedora-updates.repo

check out that file - see if you can see what's eaten it.



Note You need to log in before you can comment on or make changes to this bug.