Bug 195218 - vnc reports wrong ip address under anaconda vnc install
vnc reports wrong ip address under anaconda vnc install
Status: CLOSED DUPLICATE of bug 197721
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
David Lawrence
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 11:19 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 05:14:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-06-14 11:19:05 EDT
Description of problem:
This is an odd one as I have 1 system where I see it and one where I don't.
Doing a rawhide vnc install on ia64 I have a system who's ip address is
10.12.11.11 however when anaconda starts vnc it reports the ip wrong:


The VNC server is now running.
Please connect to 152.162.59.3:1 to begin the install...
Starting graphical installation...

I have verified that the system IS using the right ip address and if I point
vncviewer to the right ip I see that vnc is running just fine.

Version-Release number of selected component (if applicable):
rawhide-20060614
anaconda-11.1.0.33-1
vnc-server-4.1.2-2

How reproducible:
every time on one system, never on another, will try other systems

Steps to Reproduce:
1. do a vnc install and verify the ip address that is reported
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jitka Kozana 2006-06-15 03:58:05 EDT
These two machines are both ia64? Or you are experiencing this bug only on 
ia64 architecture?
Comment 2 Doug Chapman 2006-06-15 10:15:42 EDT
both of these were ia64.  Here are the differences that _might_ be why one works
and one doesn't:

broken system:
using eth0 which is an e1000, ip is 10.12.11.11

working system:
using eth1 which is an e100 device, ip is 10.12.11.31

I have other systems I will try this on today to see where else it works/does
not work.  All of my hardware here is ia64 but I have an x86_64 at home I can
experiment with as well possibly tomorrow.
Comment 3 Doug Chapman 2006-06-15 13:07:51 EDT
OK, I tried this on 4 HP Integrity ia64 systems.  The only one that gives the
right ip is the one that uses eth1.  All the others (using eth0) give what
appears to be a random number for the ip address.

I will re-cable this to use eth0 just to confirm that is the difference.  Not
sure if that gets us closer to why it is broken but bothers me that it works on
just this one!  I like consistency ;)
Comment 4 Mark McLoughlin 2006-08-02 05:14:51 EDT
Okay, looks like this was fixed by this:

* Fri Jul  7 2006 David Cantrell <dcantrell@redhat.com> - 11.1.0.54-1
...
- Use configured interface for VNC connections (clumens, #197721)

Re-open if not




*** This bug has been marked as a duplicate of 197721 ***

Note You need to log in before you can comment on or make changes to this bug.