Bug 195234 - python update breaks dependencies
python update breaks dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 11:40 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.4.3-0.9.FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 16:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-06-14 11:40:07 EDT
Description of problem:

FC5 has the following core package - python-docs-2.4.2-1.1.noarch.rpm
If this was installed then the latest update to python-2.4.3-4.FC5
is refused because 'python-docs' explicitely requires python-2.4.2.
Or, if you prefer, after python update 'yum install python-docs'
fails.

If 'python-docs' indeed does not need a new version then maybe
an explicit 'Provide: python-2.4.2' in new packages would be good
enough?  OTOH maybe 'python-docs' requirements do not need to be
down to a minor version specific?

Version-Release number of selected component (if applicable):
python-2.4.3-4.FC5
Comment 1 Mihai Ibanescu 2006-06-14 16:48:26 EDT
Updated python-docs are available.

Note You need to log in before you can comment on or make changes to this bug.