Bug 195252 - Evolution hogs the CPU with the latest updates
Evolution hogs the CPU with the latest updates
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 12:19 EDT by William Lovaton
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: evolution-connector-2.6.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 22:13:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 344196 None None None Never

  None (edit)
Description William Lovaton 2006-06-14 12:19:01 EDT
Hi, after applying the latest evolution updates, Evolution won't work correctly
with my Exchange account.  It was working fine before the updates.

Basically evolution will hang using 100% of the CPU when trying to watch an
email with attachments in the Exchange account.  The funny thing is that it
doesn't block the GUI, I can use the menus, quit the application but it wont
show any mail after the block.  This problem is triggered by mails with
attachments, I usually can read through my mails that doesn't have attachments
without any problem before triggering the bug.

There have been some discussion in this two forums posts:
http://forums.fedoraforum.org/forum/showthread.php?t=112708&highlight=evolution
http://forums.fedoraforum.org/forum/showthread.php?t=112886&highlight=evolution

And I reported the bug upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=344656

In that bug report there are some backtraces and more information that could be
of relevance to fix this problem.

Looking at the forum posts and the b.g.o bug report, there are many people
seeing this problem.
Comment 1 William Lovaton 2006-06-15 09:07:11 EDT
Please... really... take a look at http://bugzilla.gnome.org/show_bug.cgi?id=344656

There have been a lot of findings in that bug report, maybe this is a Red Hat
specific bug and somebody here could give us a hand.  There are a lot of people
suffering this problem and I refuse to go back to the old version without
resolving the issue first... even if evolution is a critical piece of my day to
day work.
Comment 2 William Lovaton 2006-06-27 17:20:50 EDT
Is there anyone looking at this problem??  There have been a lot of talk in the
upstream bug report:
http://bugzilla.gnome.org/show_bug.cgi?id=344196
Comment 3 Matthew Barnes 2006-08-08 23:04:52 EDT
Are you still seeing this behavior with evolution 2.6.3 and co.?

Have you been able to determine whether this is a Fedora-specific bug, or are
users of other distros are seeing this too?  I have only skimmed through the
upstream bug reports.
Comment 4 Mathias Nicolajsen Kjærgaard 2006-08-09 06:42:11 EDT
The problem seems to go away when I upgraded to 2.6.3 (yum
--enablerepo=updates-testing update evolution-connector). Thanks!
Comment 5 Matthew Barnes 2006-08-09 06:51:24 EDT
William, can you confirm that the problem is fixed in evolution 2.6.3?
Comment 6 Need Real Name 2006-08-09 09:02:56 EDT
WFM too :) phew!
Comment 7 Matthew Barnes 2006-08-14 22:13:56 EDT
Based on comments here as well as in the upstream bug report, the consensus
seems to be that Evolution 2.6.3 fixes the excessive CPU usage.  So I'm going to
close this bug, but please re-open it if you find that you are still seeing the
problem.

Note You need to log in before you can comment on or make changes to this bug.