Bug 19528 - 2 syntax errors in the up2date script
Summary: 2 syntax errors in the up2date script
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 21361 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-21 21:38 UTC by Dan Gindikin
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-21 21:39:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:138 high SHIPPED_LIVE New, enhanced Update Agent for Red Hat Linux 6.x, 7.0 available 2000-12-21 05:00:00 UTC

Description Dan Gindikin 2000-10-21 21:38:57 UTC
I saw both of these buglets, when I executed this command:

up2date --nosig openssh openssh-clients openssh-server sysklogd sysstat
up2date apache gnupg

This was on a vanilla RH 7.0 intallation.

E X C E P T I O N
-----------------
Traceback (innermost last):
  File "/usr/sbin/up2date", line 382, in ?
    main()
  File "/usr/sbin/up2date", line 366, in main
    sys.exit(batchRun(onlyList, pkgNames))
  File "/usr/sbin/up2date", line 195, in batchRun
    for index in range(updated):

F I X
-----
change line 195 to
    for index in range(len(updated)):


E X C E P T I O N
-----------------
Traceback (innermost last):
  File "/usr/sbin/up2date", line 382, in ?
    main()
  File "/usr/sbin/up2date", line 366, in main
    sys.exit(batchRun(onlyList, pkgNames))
  File "/usr/sbin/up2date", line 197, in batchRun
    print "%s\nSelecting %s for update." % e.errmsg, e.pkgName

F I X
-----
change line 197 to
    print "%s\nSelecting %s for update." % (e.errmsg, e.pkgName)

Once I made these two changes, it ran and installed everything fine.

Comment 1 Preston Brown 2000-11-28 16:18:43 UTC
both of these buglets have been removed by code changes in a new update agent
errata due to arrive this week.

Comment 2 Preston Brown 2000-11-28 19:41:42 UTC
*** Bug 21361 has been marked as a duplicate of this bug. ***

Comment 3 Preston Brown 2000-11-28 20:07:21 UTC
*** Bug 21361 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.