Bug 195347 - libacl-devel contains broken .la file
libacl-devel contains broken .la file
Status: CLOSED DUPLICATE of bug 171114
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: acl (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 17:07 EDT by Elijah Newren
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 14:27:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elijah Newren 2006-06-14 17:07:59 EDT
Description of problem:
The /usr/lib/libacl.la file from libacl-devel is broken.  It causes compilation
bugs like the following (found when compiling the development version of
gnome-vfs which just recently gained acl support):

/bin/sh ../libtool --tag=CC --mode=link gcc  -g -O2   -o libfile.la -rpath
/opt/gnome2/lib/gnome-vfs-2.0/modules -export_dynamic -avoid-version -module
-no-undefined file-method.lo fstype.lo file-method-acl.lo   -lattr -lacl -lfam
-pthread -L/opt/gnome2/lib -lgobject-2.0 -lgconf-2 -lORBit-2 -lm -lgmodule-2.0
-ldl -lgthread-2.0 -lglib-2.0 -liconv   ../libgnomevfs/libgnomevfs-2.la -lutil
-lrt -lrt
grep: /lib/libattr.la: No such file or directory
/bin/sed: can't read /lib/libattr.la: No such file or directory
libtool: link: `/lib/libattr.la' is not a valid libtool archive
make[2]: *** [libfile.la] Error 1
make[2]: Leaving directory `/export/home/b/newrenTemp/gnome/gnome-vfs/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home/b/newrenTemp/gnome/gnome-vfs'
make: *** [all] Error 2

Version-Release number of selected component (if applicable):
libacl-devel-2.2.23-5

How reproducible:
100%

Additional info:
This is caused by /usr/lib/libacl.la trying to refer to a file from
libattr-devel, but getting the path wrong.  The fix is trivial; just apply the
following patch

--- /usr/lib/libacl.la.orig      2004-09-16 14:34:23.000000000 -0600
+++ /usr/lib/libacl.la  2006-06-13 16:50:41.000000000 -0600
@@ -14,7 +14,7 @@
 old_library='libacl.a'

 # Libraries that this one depends upon.
-dependency_libs=' /lib/libattr.la'
+dependency_libs='/usr/lib/libattr.la'

 # Version information for libacl.
 current=2
Comment 1 Matthew Miller 2006-11-27 14:17:11 EST
This is a dup of bug #171114. However, I don't have the power to resolve it as such.
Comment 2 Jindrich Novy 2006-11-27 14:27:44 EST

*** This bug has been marked as a duplicate of 171114 ***

Note You need to log in before you can comment on or make changes to this bug.