Bug 195354 - lpstat -p incorrectly reports current job
lpstat -p incorrectly reports current job
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cups (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-06-14 17:20 EDT by Bill Peck
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0225
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 18:50:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2006-06-14 17:20:36 EDT
Description of problem:
lpstat -p incorrectly reports current job

Version-Release number of selected component (if applicable):
All versions of RHEL4.  Works fine with RHEL3

How reproducible:
Everytime

Steps to Reproduce:
1. install any RHEL4 flavor
2. run the /CoreOS/cups/lpstat/now-printing in rhts
  
Actual results:
+ lp -H hold -dn1 /usr/share/cups/data/testprint.ps
request id is n1-1 (1 file(s))
+ lp -dn1 /usr/share/cups/data/testprint.ps
request id is n1-2 (1 file(s))
+ lpstat -p n1
+ tee lpstat-p-output
printer n1 now printing n1-1.  enabled since Jan 01 00:00


Expected results:
+ lp -H hold -dn1 /usr/share/cups/data/testprint.ps
request id is n1-1 (1 file(s))
+ lp -dn1 /usr/share/cups/data/testprint.ps
request id is n1-2 (1 file(s))
+ lpstat -p n1
+ tee lpstat-p-output
printer n1 now printing n1-2.  enabled since Jan 01 00:00
+ set +x

Additional info:
Link to additional runs in RHTS.
http://rhts.lab.boston.redhat.com/cgi-bin/rhts/test_list.cgi?lower=1&upper=25&first_lower=1&first_upper=25&last_lower=150&last_upper=165&next_lower=26&next_upper=50&prev_lower=1&prev_upper=25&prev_sort_char=&result=Fail&result=Pass&test_filter=%2FCoreOS%2Fcups%2Flpstat%2Fnow-printing&system_filter=&package_filter=
Comment 2 RHEL Product and Program Management 2006-08-18 11:30:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Red Hat Bugzilla 2007-05-01 18:50:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0225.html

Note You need to log in before you can comment on or make changes to this bug.