Bug 195398 - Undefined video modes due to missing BuildRequires
Undefined video modes due to missing BuildRequires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Thomas Woerner
: Reopened
: 196445 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 20:01 EDT by Wart
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-19 13:30:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix spec file (1.72 KB, patch)
2006-06-20 20:41 EDT, Christopher Stone
no flags Details | Diff

  None (edit)
Description Wart 2006-06-14 20:01:11 EDT
Description of problem:
/usr/include/SDL/SDL_config.h contains a whole bunch of undefined video modes,
such as the all-important SDL_VIDEO_DRIVER_X11.  I have seen this cause build
errors for other applications that include SDL_syswm.h (such as xpilot-ng in
Fedora Extras)

This is due to the fact that SDL's confiugre script thinks that X isn't
installed when running configure, because a few X headers are missing:
checking for X... no

The root of this problem is a missing BuildRequires: libXt-devel.

Version-Release number of selected component (if applicable):
1.2.10-2

How reproducible:
Always

Steps to Reproduce:
1. Install SDL-devel-1.2.10-2
2. Look at the video modes defined in /usr/include/SDL/SDL_config.h
  
Actual results:
SDL_VIDEO_DRIVER_X11 is not defined


Expected results:
SDL_VIDEO_DRIVER_X11 is defined

Additional info:
Two other BuildRequires that add useful functionality to SDL are
libXrender-devel and libXrandr-devel.

Additionally, the BuildRequires: mesa-libGL-devel mesa-libGLU-devel should be
the more generic libGL-devel and libGLU-devel.
Comment 1 Christopher Stone 2006-06-20 20:41:25 EDT
Created attachment 131241 [details]
Patch to fix spec file

Attached is a patch to fix this spec file to *hopefully* speed this bug
along...
Comment 2 Hans de Goede 2006-06-23 04:05:58 EDT
Notice that this not only breaks building SDL using apps but that this also
break running most SDL using apps as the SDL library itself has been build
without X support!

Due to this all SDL using apps in test1 are broken, please fix this in Rawhide asap.
Comment 3 Patrice Dumas 2006-06-26 05:08:02 EDT
*** Bug 196445 has been marked as a duplicate of this bug. ***
Comment 4 Warren Togami 2006-06-26 11:01:48 EDT
Should be fixed in -3 in tomorrow's rawhide.
Comment 5 Warren Togami 2006-06-26 16:49:13 EDT
I undid my patch and used Chris' from above instead.
Comment 6 Warren Togami 2006-06-26 16:56:52 EDT
Chris' patch causes a failure on x86_64.  Leaving it at -3 for now.  Please
supply additional patches against -3.

RPM build errors:
    File not found by glob: /var/tmp/SDL-1.2.10-root/usr/share/man/man3/SDL*.3*

Comment 7 Florian La Roche 2006-07-17 04:07:02 EDT
Warren, is the above problem corrected already?

Thanks,

Florian La Roche
Comment 8 Hans de Goede 2006-08-19 13:30:57 EDT
This been fixed a long time now, closing.

Note You need to log in before you can comment on or make changes to this bug.