Bug 195426 - ypserv complains "o_ypcall: Timed out" in my XeonLV
ypserv complains "o_ypcall: Timed out" in my XeonLV
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ypserv (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 01:29 EDT by Eric Zhang
Modified: 2015-01-07 19:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 10:55:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Zhang 2006-06-15 01:29:37 EDT
Description of problem:
I am running RedHat Enterprise Linux AS4U2 on my XeonLV cluster. In order to 
run my parallel job, I installed MPICH-1.2.5.2, certainly, I have installed 
ypserv, ypbind, nfs, rsh, etc.

The problem is when I startup a parallel job just like `mpirun -np 16 -
machinefile myhosts mpihelloworld', ypserv complains:

[compute1] /home/kartwall/testcode > /usr/local/mpich/bin/mpirun -np 16 -
machinefile hostfile hello
o_ypcall: clnt_call: RPC: Timed out
p0_18235:  p4_error: Child process exited while making connection to remote 
process on compute2: 0

I know that in ypserv-2.13-9 version, this is a ypserv bug and it can be fixed 
if we downgrade ypserv to ypserv-2.13-5. But my ypserv is ypserv-2.13-5 now. 
Another interesting thing is that the error message above is "o_ypcall" while 
not "do_ypcall". 

I have tried to upgrade my ypserv to `ypserv-2.13-11' but it doesn't work 
still.

I think that maybe ypserv doesn't support XeonLV now. I have found a lot of 
softwares on my XeonLV platform don't work correctly. And on my another 
cluster which is based on Xeon, ypserv-2.13-5 works well.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Steve Dickson 2006-12-22 13:08:24 EST
> I know that in ypserv-2.13-9 version, this is a ypserv bug and it can be fixed 
Which bug are you talking about?
Comment 4 Daniel Riek 2007-01-30 10:55:31 EST
As this has been in needinfo for a long time with no movement the decision is to
close WONTFI. Please re-open with the requested information if the problem persists.

Note You need to log in before you can comment on or make changes to this bug.