Bug 195434 - Curl program dies sometimes
Curl program dies sometimes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 03:34 EDT by Ivana Varekova
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 10:23:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivana Varekova 2006-06-15 03:34:16 EDT
Description of problem:

curl_resolv can die, here is the valgrind output:

==2835== Warning: client switching stacks?  SP change: 0xBEB0FD2C --> 0xD0678F0
==2835==          to suppress, use: --max-stackframe=1314225092 or greater
==2835== Invalid write of size 4
==2835==    at 0x40F67BD: Curl_resolv (in /usr/lib/libcurl.so.3.0.0)
==2835==  Address 0xD0678F4 is on thread 1's stack
==2835== Can't extend stack to 0xD067390 during signal delivery for thread 1:
==2835==   no stack segment
==2835==
==2835== Process terminating with default action of signal 11 (SIGSEGV)
==2835==  Access not within mapped region at address 0xD067390
==2835==    at 0x40F67BD: Curl_resolv (in /usr/lib/libcurl.so.3.0.0)


Version-Release number of selected component (if applicable):
curl-7.15.1-3


How reproducible:
>From time to time


Steps to Reproduce:
1. Run clamd with followurls enabled
2.
3.
  
Actual results:
See valgrind output

Expected results:


Additional info:

This was reported some time ago and I was assured that by FC5 it would be fixed,
but it hasn't been :-(


------- Additional Comments From daniel@haxx.se  2006-06-12 07:22 EST -------
1. You stopped responding to that other bug so of course they closed it.

2. Any chance you can get a nice 'bt' trace output from the crash?

3. Any chance you produce a somewhat easier (stand alone) way to repeat this
problem? I don't have FC5 nor do I have clamd for it, but I would be
intesterested to investigate the problem.


------- Additional Comments From mbacovsk@redhat.com  2006-06-13 05:15 EST------
I tried to reproduce your bug, but I was obiously unsuccessfull. I used
curl-7.15.1-3 and clamav-server-0.88.2-1.fc5. In /etc/clamd.conf I enabled 
ScanMail and MailFollowURLs. No errors appeared.

Can you please post more accurate description how to produce reported bug? Info
about 
- what else needs to be configured 
- which version of clamd you use
- how to run clamav
- where to expect error 
would be nice.


------- Additional Comments From njh@bandsman.co.uk  2006-06-13 05:19 EST ------
I am using the version of clamav-milter from CVS (well I would be wouldn't I,
I'm the author!)

What happens is I run clamav-milter under valgrind with MailFollowURLs enabled
and that error occurs after a bit of time.


------- Additional Comments From mbacovsk@redhat.com  2006-06-13 07:32 EST -------
I ran clamav-milter like this:
valgrind --tool=memcheck --num-callers=25 --leak-check=yes clamav-milter
--max-children=10 25
It scaned a few different mails I sent through local sendmail, but still no errors.
Please send me how you run clamav-milter, if it differs. I also would need
example email which can cause that error (I assume the error is content dependent).

Note You need to log in before you can comment on or make changes to this bug.