Bug 195446 - RFE: re-init repositories in "background"
RFE: re-init repositories in "background"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-15 04:59 EDT by Moritz Barsnick
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-18 04:11:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2006-06-15 04:59:33 EDT
Description of problem:
Request for enhancement: After processing an install/update queue, the 
automatic repository reinitialization (download repodata, rebuild lists) should 
start in the background, and not wait until the user has pressed "okay" in the 
popup "Finished processing".

Version-Release number of selected component (if applicable):
1.0.1-1.0.fc5

How reproducible:
always

Steps to Reproduce:
1. start yumex
2. select some updates of installations into queue
3. process queue

Actual results:
After step 3, a popup occurs, basically saying that yumex finished the queue 
and installed successfully. _After_ pressing okay, yumex starts reinitializing 
the repo data (downloading xmls, creating the lists I guess, ...).

Expected results:
After step 3, yumex goes ahead and reinitializes the repodata without waiting 
for the user. Nevertheless, it reports to the user that his/her previous action 
ended successfully. (Well, if it didn't end successfully, I guess it will offer 
to do something afterwards different than re-initing the repos anyway.)

Additional info:
Reason for request: I'm inpatient. ;-) Basically, I want to get back to the 
package lists, but re-initializing the repodata takes a few minutes (especially 
since I have Extras in there, and since mirrors can be darn slow).

With this enhancement, when I return to the Yumex window - in case I wasn't 
watching - it will already be almost ready to work again.

Great tool, anyway! Good work!
Comment 1 Tim Lauridsen 2006-06-18 04:11:53 EDT
Sounds very sane to me, i will put it on ToDo list.

Note You need to log in before you can comment on or make changes to this bug.