This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 19545 - gcc segfaults when compiling wv-0.6.1
gcc segfaults when compiling wv-0.6.1
Status: CLOSED DUPLICATE of bug 19392
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-22 09:29 EDT by Nick Urbanik
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-22 09:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The spec file I used with rpm -ba wv.spec (2.30 KB, text/plain)
2000-10-22 09:32 EDT, Nick Urbanik
no flags Details
The output of rpm -ba wv.spec 2>&1 | tee wv.spec-2.log (42.56 KB, text/plain)
2000-10-22 09:35 EDT, Nick Urbanik
no flags Details

  None (edit)
Description Nick Urbanik 2000-10-22 09:29:55 EDT
I edited the wv.spec from 7.0 powertools to update to wv-0.6.1.
rpm -ba results in a segfault from gcc.
Attached: the spec file I used, and the output from the compilation.
Comment 1 Nick Urbanik 2000-10-22 09:32:27 EDT
Created attachment 4493 [details]
The spec file I used with rpm -ba wv.spec
Comment 2 Nick Urbanik 2000-10-22 09:35:15 EDT
Created attachment 4494 [details]
The output of rpm -ba wv.spec 2>&1 | tee wv.spec-2.log
Comment 3 Nick Urbanik 2000-10-22 09:38:38 EDT
Note: this is an upgraded RH system, with all updates applied, including
glibc-2.1.94-3.i686.rpm.  This is a PIII.

I'm sorry I don't have time to produce a minimal program to reproduce this bug,
but perhaps you people may wish to follow this up.
Comment 4 Jakub Jelinek 2000-10-23 03:42:23 EDT
The wv part should be fixed in wv 0.6.2 (at least wv developers told me),
the gcc segfault (gcc should obviously not crash even on bad input) is fixed
in 2.96-57 (in rawhide) and above and will appear in the next gcc errata.

*** This bug has been marked as a duplicate of 19392 ***

Note You need to log in before you can comment on or make changes to this bug.